Sommaire

Les Mathématiques
Musique "Invention BWV784" J.S. BACH 1685-1750

MATHEMATIQUES

pour l'Electronique

Nous veillons aux respects des droits d'auteur : si par erreur un contenu protégé est disponible sans indication sur ce site, merci de contacter l'administrateur, il sera retiré ou mis à jour dans les plus brefs délais.


... Cercle Trigonométique ... Courbe Sinus Cosinus et Tangente

Le cercle trigonométrique


Vu dans ... http://www.silicium628.fr

ELECTRONIQUE PROGRAMMABLE

Théorie et Applications
  • Math
  • Physique
    • Mesure de la vitesse de la lumière
      • Avec un laser
      • Avec une ligne de Lecher
    • Calcul de l'atome d'hydrogène
    • Grandeurs physiques et équations aux dimensions
    • Notion de champ électrique
    • Ondes Progressives et Stationnaires
  • Astrono
    • GO-TO pour monture équatoriale
    • Existe-t-il des univers multiples ?
  • ATmega
    • Programmation des ATmega en C
    • Geany comme EDI pour programmer les ATmega en C
    • Comment relier électriquement une SD card à un ATmega
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Géné 1Hz à 100MHz à DDS AD9850 piloté par GPS
    • Un distributeur de nourriture (ATmega8)
    • Programmateur pour Lave Linge (ATmega32)
    • Capacimètre Numérique (ATmega8)
    • Contrôleur pour moteur Brushless (ATmega8)
  • Arduino
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Geany comme EDI pour programmer les ARDUINO
    • Machine CNC de phototraçage de typons par diode laser 405nm
  • HF
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
    • Géné HF 90MHz sinus
    • Géné HF 160MHz sinus
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Générateur de fréquences numérique
    • Oscillateur à NE555
  • GPS - Rubidium
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
  • Automat
    • Un distributeur de nourriture
    • Déclencheur auto pour APN
    • Programmateur pour Lave Linge
    • Positionneur parabole TV satellite
    • DIGIPRESS-96 coffrage-sous vide
  • Mesure
    • Capacimètre Numérique
    • Le CAPACIM 97 pour accus
    • Grip-Dip
  • Aéro
    • Variateur électronique pour moteur SPEED 400
    • Contrôleur (variateur) pour moteur Brushless (avec un PIC16F628)
    • Contrôleur (variateur) pour moteur Brushless (avec un ATmega8)
    • Variateur double pour hélico indoor
  • Alims
    • Alim stabilisée 20V 5A à découpage
    • Alim 20V 4A à découpage, numérique pilotée par ATmega8
    • Nouvelle Alim 20V 4A à découpage, numérique pilotée par ATmega8
  • Progr
    • Programmer en C et Qt4 pour Linux
    • Programmer en C++ et Qt4 sur RASPBERRY PI
    • Décodage d'une trame RC5 (télécommande TV)
    • Programmation des AVR en langage C, sous LINUX
    • Planétarium en C++ & Qt4
    • Visualiseur d'images stéréoscopiques en C++ & Qt4
    • Transformée de Fourier (Programme en C++ et Qt4)
    • Transformée de Fourier Rapide FFT (Programme en C++ et Qt4)
  • 3D
    • Méthode de visualisation d'images en relief
  • MUSIQUE
  • Vidéo
  • LIVRES
    • Afficher tous les titres
  • Mes sites
    • (dont je suis le concepteur)
    • BOUB'ART Sculpture
    • BOUB'ART Recup
OSCILLATEUR à NE555

Théorie et Pratique

Cette réalisation constitue l'application pratique de l'étude mathématique de la charge d'un condensateur au travers d'une résistance, exposé dans un article sur ce site.
(Voir cet article)
Table des matières :
1 - Le schéma
2 - Etude théorique
3 - Application pratique: avec R=100k et C=10nF
4 - Signal au bornes du condensateur:
5 - Le test du fréquencemètre:
1 Le schéma

La tension aux bornes du condensateur est présentée sur les entrées de deux comparateurs, qui la comparent donc (de par leur câblage interne) à 1/3 Vcc et à 2/3 Vcc. Ces comparateurs commandent une bascule flip/flop. La sortie de la bascule (sortie logique au niveaux TTL) est mise en forme aux niveaux CMOS (0V et Vcc) par deux inverseurs à hystérésis en série (afin qu'ils... n'inversent pas). Le résultat est que lorsque le condensateur se charge et qu'il atteint la tension 2/3 Vcc, la bascule bascule, ce qui le fait se décharger à travers la résistance. Lorsqu'il atteint 1/3 Vcc la bascule revient dans l'état précédent, ce qui provoque le rechargement du condensateur à travers la même résistance, jusqu'à 2/3 Vcc, et ainsi de suite... La courbe de charge et de décharge est une fonction en 1-exp(-t/RC) comme vu dans mon article cité plus haut.

2 Etude théorique

Le condensateur à mesurer est connecté sur le NE55 et forme un oscillateur astable dont la tension triangulaire est symétrique (dans le temps) parce que j'utilise la sortie Q pour alimenter le condensateur (et pas la sortie "discharge")

La tension du condensateur évolue donc entre les deux seuils des comparateurs du NE555, c'est à dire +1/3 Vcc et +2/3 Vcc en étant alimenté par Vcc (ou 0)

Pour monter de +1/3 Vcc jusqu'à +2/3 Vcc cela représente une marche de hauteur 2/3-1/3 = 1/3 VCC. Au départ de cette marche le condensateur est chargé à 1/3 Vcc. Il reçoit une alim = Vcc (= 3/3 Vcc) (par la sortie Q du NE555 et à travers la résistance).

On voit qu'on part de 1/3, on arrête la charge à 2/3 on alimente sous 3/3

Décalons tout mentalement de 1/3 vers le bas (ce qui ne change rien au principe mais est plus clair pour le calcul ): on part maintenant de 0, on arrête à 1/3 Vcc, on alimente sous 2/3 Vcc. ce qui revient à dire qu'on part de 0, on arrête à 50% de la tension appliquée.

et ainsi les choses deviennent très simples pour calculer la période...
Il s'agit de calculer l'équation:

1-exp(-t/RC) = 1/2

exp(-t/RC) = 1-1/2 = 1/2
-t/RC = ln (1/2) (log néperien, pas log décimal...)
t/RC = ln 2 = 0.69 (puisque ln(1/x) = - ln(x) )

t= 0.69 RC

Evidemment il faut ajouter le temps de décharge entre 2/3 VCC et 1/3 VCC qui est identique.
dont Ttotal = 2*t = 1.38 RC.

3 Application pratique: avec R=100k et C=10nF

La calculatrice nous prédit une fréquence de 724,6 Hz.

4 Signal au bornes du condensateur:

C'est un signal en triangulaire dont les cotés sont courbes. On peut parler de "scie émoussée"...

5 Le test du fréquencemètre:

Le résultat est en accord avec la théorie, c'est le moins qu'on puisse dire!

6 -

A voir également...

Ce site est développé en PHP avec des LOGICIELS LIBRES sous LINUX


Silicium628

ELECTRONIQUE PROGRAMMABLE

Théorie et Applications

Vu dans ... http://www.silicium628.fr

  • Math
  • Physique
    • Mesure de la vitesse de la lumière
      • Avec un laser
      • Avec une ligne de Lecher
    • Calcul de l'atome d'hydrogène
    • Grandeurs physiques et équations aux dimensions
    • Notion de champ électrique
    • Ondes Progressives et Stationnaires
  • Astrono
    • GO-TO pour monture équatoriale
    • Existe-t-il des univers multiples ?
  • ATmega
    • Programmation des ATmega en C
    • Geany comme EDI pour programmer les ATmega en C
    • Comment relier électriquement une SD card à un ATmega
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Géné 1Hz à 100MHz à DDS AD9850 piloté par GPS
    • Un distributeur de nourriture (ATmega8)
    • Programmateur pour Lave Linge (ATmega32)
    • Capacimètre Numérique (ATmega8)
    • Contrôleur pour moteur Brushless (ATmega8)
  • Arduino
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Geany comme EDI pour programmer les ARDUINO
    • Machine CNC de phototraçage de typons par diode laser 405nm
  • HF
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
    • Géné HF 90MHz sinus
    • Géné HF 160MHz sinus
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Générateur de fréquences numérique
    • Oscillateur à NE555
  • GPS - Rubidium
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
  • Automat
    • Un distributeur de nourriture
    • Déclencheur auto pour APN
    • Programmateur pour Lave Linge
    • Positionneur parabole TV satellite
    • DIGIPRESS-96 coffrage-sous vide
  • Mesure
    • Capacimètre Numérique
    • Le CAPACIM 97 pour accus
    • Grip-Dip
  • Aéro
    • Variateur électronique pour moteur SPEED 400
    • Contrôleur (variateur) pour moteur Brushless (avec un PIC16F628)
    • Contrôleur (variateur) pour moteur Brushless (avec un ATmega8)
    • Variateur double pour hélico indoor
  • Alims
    • Alim stabilisée 20V 5A à découpage
    • Alim 20V 4A à découpage, numérique pilotée par ATmega8
    • Nouvelle Alim 20V 4A à découpage, numérique pilotée par ATmega8
  • Progr
    • Programmer en C et Qt4 pour Linux
    • Programmer en C++ et Qt4 sur RASPBERRY PI
    • Décodage d'une trame RC5 (télécommande TV)
    • Programmation des AVR en langage C, sous LINUX
    • Planétarium en C++ & Qt4
    • Visualiseur d'images stéréoscopiques en C++ & Qt4
    • Transformée de Fourier (Programme en C++ et Qt4)
    • Transformée de Fourier Rapide FFT (Programme en C++ et Qt4)
  • 3D
    • Méthode de visualisation d'images en relief
  • MUSIQUE
  • Vidéo
  • LIVRES
    • Afficher tous les titres
  • Mes sites
    • (dont je suis le concepteur)
    • BOUB'ART Sculpture
    • BOUB'ART Recup
Appareils de mesures
INDUCTANCEMETRE
10 oct 2015 Si vous disposez d'un fréquencemètre montant à 200MHz (ou plus) ou d'un analyseur de spectre (ou les deux), ce petit circuit oscillateur vou...
SDcard data Recorder - ATmega32 + LCD 5110
10 juil 2015 Ce montage permet d'enregistrer en temps réel, c'est à dire rapidement, une grande quantité de données logiques. Je l'ai conçu afin de surve...
Oscillo HAMEG HM303-4 : ajout d'un ATmega 8 !
05 oct 2014 Un sélecteur digital pour la base de temps....
CAPACIMETRE NUMERIQUEbasé sur un ATmega8
07 dec 2005 Je vous ai déjà parlé ici de ces puissants microcontrôleurs RISC que sont les AVR ATMEGA8-16. Voici ma première réalisation avec l'un d'e...

Maths : Nombres complexes - Analyse harmonique - Transformée de Fourier

  • Les Nombres complexes
  • Fonctions dérivée et primitive
  • Intégration
  • Le logarithme Népérien
  • La Fonction exponentielle de base e
  • Dérivées des fonctions log et exp(x)
  • Dérivées des fonctions sin et cos
  • Forme exponentielle des nb. complexes
  • Equations diff. du 1er ordre
  • Calcul de la charge C à travers R
  • Oscillateur à NE555
  • Impédance complexes des R - L - C
  • Equations diff. du second ordre
  • Oscillateur harmonique LC
  • Oscillateur harmonique amorti RLC
  • Calcul filtre passe-bas premier ordre
  • Filtre passe-bas second ordre
  • Circuit bouchon RLC
  • Filtre RC et oscillateur en pont de Wien
  • Oscillateur à pont de Wien
  • Calcul du Filtre de Rauch
  • Série de Fourier. Analyse harmonique
  • Le Produit de convolution
  • Fonction (Distribution) de Dirac
  • Transformée de Fourier. Etude analytique
  • La Transformée de Fourier Rapide (FFT)
  • Transformée de Fourier d'un train de sinusoïdes
  • Transf. de Laplace. Rép. impulsionnelle
  • CALCUL VECTORIEL
  • Ondes Progressives et Stationnaires
  • Conv. N/A à réseau R-2R
  • Conv. A/N par approx. successives
  • Calcul de pi (pourquoi pi = 3,14159....)
[ Retour Accueil ]
Ce site est développé en PHP avec des LOGICIELS LIBRES sous LINUX


Nombres complexes

Les nombres complexes (1)

Invention:

L'idée d'un nombre imaginaire:

Nous savons que le produit de deux nombres positifs donne un nombre positif. En particulier le carré d'un nombre positif qui est égal au produit de ce nombre par lui-même donne un nombre positif. ex:

De même le produit de deux nombres négatifs donne un également nombre positif. En particulier le carré d'un nombre négatif qui est égal au produit de ce nombre par lui-même donne un nombre positif. ex: = +25

Il n'y a, à priori, pas d'autre cas de figure pour obtenir un carré, peut-on donc conclure qu'un carré est toujours un nombre positif? Non, ça montre que le carré de n'importe quel nombre réel est positif.

Mais cela ne démontre pas que tout carré est positif.

On peut imaginer que le carré de quelque chose qui ne serait pas un nombre ordinaire, pas un nombre réel, appelons le un nombre imaginaire, serait négatif. C'est de la folie? Mais non! simplement de l'imagination. Comme le fut l'invention des nombres négatifs...

Appelons ce nombre imaginaire [image] (i comme... imaginaire) et décidons que sont carré soit négatif et vaille [image].

Représentation:

Mais alors, combien vaut ce [image] ? Eh bien il vaut [image] et c'est tout! ou encore [image] . Oui mais... ça ressemble à quoi un [image] imaginaire ? A quelque chose qui multiplié par lui même vaut

Oui mais on aimerait quand même le voir ce nombre imaginaire nous! Bon d'accord, je vais le dessiner. Mais auparavant je dois vous dessiner l'image de 1, oui le nombre bien réel 1. On va le faire d'une façon géométrique. Traçons une droite horizontale pleine de points juxtaposés donc, chaque point représentant un nombre ordinaire, réel. Un de ces points représentera 0, et un autre un peu à sa droite représentera le nombre 1. Voila, avec une bonne loupe on peut voir 1.

Bon d'accord, mais [image] il est où sur cette droite? à gauche de 0 ? Non, à gauche de 0 ce sont les nombres négatifs. Le nombre imaginaire [image] n'est PAS sur cette droite! Il se trouve sur une droite perpendiculaire! Et on va voir pourquoi.

Nous avons vu plus haut que [image] vaut [image] [image] (une fois [image])

Si nous plaçons [image] sur la droite verticale à la même distance de 0 que le 1, (c'est à dire sur un cercle de centre 0 et passant par 1), on voit que le fait de multiplier 1 par [image] est l'équivalent, en partant de 1, de faire un quart de tour vers la gauche, pour trouver le résultat [image].

Dès lors qu'on connait cette astuce pour multiplier par [image], appliquons-la à [image] lui même. On part de [image] et on fait un quart de tour à gauche. On se retrouve sur la droite des nombres biens réels, sur le nombre [image]! On voit donc que ce principe opératoire de multiplication par [image] nous amène au résultat que [image] [image] c'est à dire que [image] ça correspond exactement au but recherché. On sait maintenant représenter [image].

Maintenant si partant de [image] on fait un quart de tour vers la gauche, on se retrouve à nouveau sur la droite verticale, la droite imaginaire! Et comme on peut écrire que [image] on voit que le point sur laquelle on se trouve alors, au dessous de 0 représente - [image]. Donc cette droite perpendiculaire, cette droite imaginaire ressemble fort à la droite horizontale représentant les nombres réels à par son orientation... Ses points correspondent à des nombres imaginaires, multiples de [image] [image], comme [image] ... etc ainsi que [image] [image] etc... ainsi que toutes les valeurs intermédiaires. Pour savoir où se trouve [image], il suffit de partir de [image] sur la droite des réels et de faire un quart de tour à gauche. On voit donc que par l'association de la procédure « faire un quart de tour à gauche » avec la multiplication par [image] , en partant de TOUS les points de la droite horizontale on trace en fait tous les points de la droite verticale. (tous signifie autant qu'on le désire, les réels étant en nombre infini sur tout intervalle...) C'est ce qui justifie les appellations d'axe réel et axe imaginaire «pur » pour ces deux droite. Pur ? tiens donc! Il y a autre chose? encore une complication!

Les nombres complexes:

Mais non, pire! une folie! un pas de plus pour l'imagination! On vient de représenter deux ensembles de nombres bien distincts avec nos deux droites... et qu'en est-il des AUTRES points du plan (de la feuille sur laquelle sont tracées ces droites)? Et s'ils représentaient eux aussi des nombres? Oui mais quels types de nombres? des nombres réels? non, eux ils sont tous sur la droite horizontale. Des nombres imaginaires « purs »? non plus, ils sont tous sur la droite verticale. On dira une combinaison des deux. Et on les appellera des nombres complexes.

Chaque point sera défini par ses coordonnées a et b sur les axes réel et imaginaire

et représentera un nombre complexe qui s'écrira:

Tiens nous avions appris à l'école qu'on ne peut pas ajouter des carottes et des salades? Hé bien ce n'était pas vrai! Avec un peu d'imagination on peut! Mais le résultat n'est pas carottes ni salades, mais une combinaison des deux.

Voilà, tout (enfin le principal) est dit concernant la recette des nombres complexes, le reste c'est de la cuisine.

Mais quelle cuisine! Une cuisine qui s'accommode extrêmement bien à notre plat de résistance qu'est l'électronique. Aussi elle mérite que nous l'étudions afiin de pouvoir vraiment comprendre l'électronique. C'est incontournable, l'électronique repose sur la physique, et les lois de la nature nous apparaissent essentiellement mathématiques. Feyman (et d'autres) l'avait souligné.

Autant dire, pour ceux qui sont allergiques aux math, que mes propos vont rapidement devenir désagréables... On va parler vecteurs, trigonométrie, sinus et cosinus. Puis il faudra faire un détour par la fonction logarithme néperien et sa réciproque la fonction exponentielle afiin de manier ces nombres complexes plus aisément, je dirais presque les doigts dans le nez.

Si certaines images (formules) de cette page ne s'affichent pas, voir l'autre site miroir.
Cette page (et celles qui suivent) est écrite sous Linux Ubuntu avec les logiciels libres suivants:

  • GNU TEXmacs editor (pour les formules)
  • Kig (pour les graphes)
  • Gimp (pour la retouche des images)
  • SeaMonkey composer (pour la mise en page html)
Vive le logiciel Libre!


Les nombres complexes (2)

Forme algébrique:

avec: ; [image] ;

est la partie réelle

est pa partie imaginaire

z est un nombre complexe

Autre notation:

Nombre complexe conjugué :

Le nombre complexe conjugué est noté [image] ou parfois

Si [image] , le conjugué de [image] a pour valeur :

Le conjugue a même partie réelle mais une partie imaginaire opposée.

Module

Le module d'un nombre complexe noté [image] est la distance entre le point de coordonnées (a, b) et l'origine (dans le cas de la représention géométrique dans le plan complexe). C'est en quelque sorte la « longueur » du nombre complexe.

Il a pour valeur :

Remarque :

Par conséquent :

Opérations:

Addition:

on additionne donc séparément et respectivement les parties réelles et imaginaires.

Multiplication

ici on oublie pas que [image] donc il faut remplacer [image] par

les calculs algébriques avec les nombres complexes se font donc comme avec les nombres réels à ceci près que lorsqu'on rencontre [image] on le remplace par [image].

revenons à notre multiplication:

C'est un peu compliqué sous la forme algébrique, aussi on va s'intéresser maintenant à la forme trigonométrique des nombres complexes.

Forme trigonométrique:

Le nombre complexe z peut être représenté par un vecteur

Remarque:

soit [image] l'angle

soit [image] = [image] = OM le module du vecteur (la «norme du vecteur » ou « longueur du segment OM »)

et [image] définissent complètement le vecteur [image] et donc le nombre complexe

On écrira:

est appelé le module de [image] on le notera aussi

est l'argument de

Les relations trigonométriques dans le triangle rectangle 0AM permettent d'écrire:

or nous avons vu que par définition OA représente la partie réelle de [image] et OB la partie imaginaire. Le nombre complexe [image] est la somme de sa partie réelle et de sa partie imaginaire.

On peut donc écrire (sans oublier [image] qui caractérise la partie imaginaire):

mais on sait aussi que:

on identifie les termes: et

On obtient ainsi la relation qui lie parties réelle et imaginaire (de la notation algébrique) au module et à l'argument de la notation trigonométrique.

Dans l'autre sens, les relations trigonométriques dans le triangle rectangle 0AM nous montrent que:

(le carré de l'hypoténuse est égal...) et donc

quant à l'argument on a:

Sous la forme trigonométrique l'addition devient une somme vectorielle. Ce n'est pratique que si on travaille graphiquement, ce qui est parfois le cas. La multiplication en revanche devient plus simple que sous la forme algébrique. Nous verrons ça sur la page suivante.


Les nombres complexes (3)

Opérations sous la forme trigonométrique:

Somme:

soit

en notation algébrique on obtient la somme:

Traçons [image] d'après ces coordonnées. On obtient un vecteur qui est la somme vectorielle des vecteurs représentant [image]. On aurait pu tracer ce vecteur somme par la méthode du parallélogramme.

Cette approche est utile en électronique par exemple pour comprendre la distribution spectrale d'une porteuse sinusoidale modulée en amplitude, faisant apparaitre les bandes latérales. On verra ça plus tard.

Produit:

on notera ci-dessus l'apparition du signe (-) remplaçant

une petite application des règles de trigonométrie ( [image]) donne:

On voit que:

Le produit de deux nombres complexes a comme module le produit des modules et comme argument la somme des arguments.

Quand je vous disais que la multiplication était plus simple sous cette forme...
On remarque aussi que les formules de trigo servent à quelque chose...


Forme exponentielle des nombres complexes

soit le nombre complexe

écrivons le

où [image] est la fonction exponentielle de base

1Justification de cette écriture:

nous avons vu que

or le produit sous la forme exponentielle donne:

ce qui est bien la représentation exponentielle de

En outre , on a:

de même

Ces propriétés justifient la notation :

En électronique, on utilisera le plus souvent les nombres complexes sous cette forme exponentielle.

Note 1. En électronique on désigne le nombre imaginaire [image] par la lettre [image] pour ne pas confondre avec le [image] de l'intensité (le nombre d'ampères)

2Représentation complexe d'une grandeur sinusoïdale

Une tension sinusoïdale [image] , de pulsation [image] , d'amplitude U et de phase

s'écrira:

c'est une valeur réelle, sera associée à la valeur complexe :

ou, sous sa forme exponentielle :

Il ne faudra pas perdre de vue que le signal sinusoïdal traité ne constitue que la partie réelle de ce nombre complexe.

Mais alors pourquoi se compliquer la vie en utilisant cette représentation complexe ? Parce que les calculs qui se feront dès lors sur cette valeur complexe se trouveront grandement simplifiés.

Note 2. On peut décomposer la valeur complexe en un produit de deux termes :

Note 3. On représente les grandeurs (tension, intensité) constantes par des lettres majuscules et les grandeurs instantanées par des lettres minuscules.

Note 4. Par comodité d'écriture, on confondra souvent la notation complexe avec sa partie réelle, ainsi on rencontrera la notation [image], sans la notation [image] devant. Elle est alors sous-entendue. Répétons ici qu'il ne faudra pas perdre de vue que le signal sinusoïdal traité ne constitue que la partie réelle de ce nombre complexe. Une fois les calculs faits sur les valeurs complexes, il suffira de reconsidérer la partie réelle du résultat afin de retouver LA valeur réelle.

Toutefois nous verrons ultérieurement qu'en physique quantique, les caractéristiques des particules se modélisent effectivement par des nombres complexes, et en faisant ainsi leurs propriétés qui parraissent mystérieuses lorsqu'on veut les représenter par des valeurs réelles ne le sont plus du point de vue mathématique. En particulier la « dualité onde-corpuscule ». Je cite Richard Feynman [DUNOD - ISBN 2 10 004934 8 page 8] : « En mécanique quantique il se trouve que les amplitudes doivent être représentées par des nombres complexes. Les parties réelles seules ne suffisent pas ».

3Impédance complexe du condensateur:

soit [image] (on considère que la phase [image])

Les lois élémentaires de l'électricité donnent:

(la quantité d'électricité (en Coulombs) dans le condensateur est égale au produit de la tension aux bornes par la valeur du condensateur (en Farads))

dérivons cette expression:

or nous savons que

(t est le temps)

donc

en en déduit:

Vous voyez tout le cheminement indispensable que nous avons du faire pour arriver à ce résultat essentiel: obtenir une représentation mathématique d'un composant électronique réactif. Le condensateur, au contraire de la résistance, est parcouru par un courant qui est en quadrature de phase avec la tension présente à ses bornes. Et c'est justement ce comportement complexe qui est compris dans cette formule.

On l'appelle impédance complexe du condensateur.

La prochaine fois nous calculerons l'impédance complexe de l'inductance puis nous les associerons pour voir comment se comporte mathématiquement l'ensemble.


Fonction dérivée

Calcul de quelques dérivées:

dérivée de y=x

soit la fonction

y=f(x) =x

calculons sa dérivée

Arrivé à ce stade du calcul il y a deux façons d'opérer: la bonne et la mauvaise.

Voyons tout d'abord la mauvaise: elle consiste à faire tendre tout de suite [image] vers [image] ce qui revient à annuler le numérateur ET le dénominateur simultanément. On se retrouve alors avec la fraction [image] qui n'est pas calculable (on l'appelle d'ailleurs indéterminée). En effet quel que soit [image] , [image] est égal à 0, alors que, d'autre part, quel que soit a, [image] n'est pas calculable sachant toutefois que lorsque le dénominateur d'une fraction tend vers 0, le résultat tend vers [image] (l'infini). Entre 0 et [image] il y a de la marge, il y a en fait la place pour n'importe quelle valeur réelle.

Voyons maintenant la bonne façon de procéder, (qu'il faudra TOUJOURS appliquer): Elle consiste à remarquer que la même valeur [image] se retrouve au numérateur et au dénominateur. On peut donc tout à fait simplifier par cette valeur, (on divise le numérateur et le dénominateur par cette valeur NON NULLE [image] , non nulle tant qu'on considère [image] ) et on obtient pour résultat:

Et la limite de 1 lorsque [image] c'est... 1 quel que soit [image].

On écrira:

Nous obtenons donc comme fonction dérivé de la fonction [image] qui pour tout [image] renvoie sa propre valeur [image], la fonction [image] qui pour tout [image] renvoie la valeur 1. C'est une fonction constante. Elle indique que la pente de la courbe d'équation [image] est constante ce qui n'est pas étonnant puisque la courbe en question (dans le plan affine rapporté à un repère orthonormé) est une droite (passant par 0).

Je suis entré dans les détails pour ce premier calcul, on va maintenant passer la seconde vitesse.

dérivée de

soit la fonction

avec a = nombre constant, réel.

Et voilà. Au passage on va utiliser une notation pas très rigoureuse non plus, mais pratique et généralement admise:

dérivée de

(du produit d'une fonction par une constante)

Nous pouvons utiliser ce résultat pour retrouver la dérivée de [image] sachant que nous connaissons la dérivée de [image] qui vaut 1.

la calcul est simple:

dérivée du produit de deux fonctions de

à ne pas confondre avec le produit d'une fonction avec une constante comme vu plus haut.

soit

Astuce: ajoutons la quantité nulle - [image] au numérateur (ce qui ne change rien donc):

Ce qui s'écrit:

C'est un résultat important qu'on appliquera souvent. A commencer par tout de suite!

dérivée d'une fonction composée

soit la fonction composée [image] notée également

comme par exemple [image] dans laquelle [image] et

Calculons le nommbre dérivé de la fonction [image] au point

Pour une bonne lisibilité des calculs nous utiliserons la notation suivante:

Appliquons cette définition à notre fonction composée:

Astuce: posons [image] en remarquant que

ce qui donne u(a+h)=u(a)+k

reportons cette valeur dans le calcul de A

multiplions numérateur et dénominateur par

Ce résultat nous servira (entre autre) pour démontrer la propriété fondamentale de la fonction logarithme népérien qui consiste à remplacer des multiplications pas des additions.

dérivée de

Ce qui s'écrit:

C'est simple sous cette forme n'est-ce pas? à comparer à ceci:

On retrouve bien sûr le même résultat.

dérivée de

Ce qui s'écrit:

dérivée de

utilisons la dérivée d'un produit de fonctions:

Ce qui s'écrit:

exemple: la dérivée de [image] est

C'est aussi un résultat très important.

Récapitulons:

2

Primitives de ces fonctions:

Ce n'est pas compliqué, il suffit de lire le tableau à l'envers

Les (+k) traduisent le fait que la dérivation de la constante (qui donne 0) ne change pas le résultat

puis en ajustant les constantes afin de trouver le résultat qui nous intéresse:

primitive de

AVEC

Ce n'est pas un parachutage, il suffit de dériver [image] pour retrouver

Remarque: limite de cette formule:

On ne peut pas calculer la primitive de [image] par cette formule, on bute sur un zéro au dénominateur ce qui est interdit, est donne une limite au domaine d'application de la formule comme indiqué plus haut,

Mais d'autres valeurs négatives pour [image] sont-elles permises ? Oui, tout à fait, par exemple

Autre exemple:

Fonction logarithme népérien

Remarque: Aucune de ces fonctions [image] , quel que soit n positif ou négatif différent de 1 ne donne [image] = [image] comme fonction dérivée. Aucune n'est la primitive de

en effet si on fait n=0 dans la formule de la dérivation ci-dessous

on obtient bien -1 comme puissance, mais multipliée par 0

ce qui ne fait visiblement pas la fonction [image] mais une constante nulle, 0.

Mais alors, que vaut la primitive de [image] ? Ce n'est pas une puissance de [image].

Il faut l'inventer! (enfin d'autre l'ont fait avant nous). On l'appellera la fonction logarithme népérien.

On posera par définition:

et on ajoutera: celle qui s'annule pour [image] (oui parce que toute fonction semblable qui n'en diffère que par l'ajout d'une constante est également primitive de [image])

Alors, c'est pas beau les maths? L'imagination permet de contourner bien des obstacles.

On étudiera cette fonction et sa réciproque l'exponentielle la prochaine fois.

Note: historiquement la fonction logarithme était connue par ses propriétés (le remplacement des multiplications par des additions comme on le verra) avant d'être définie comme l'intégrale de 1/x. Voir ce lien externe:


Fonctions dérivée et primitive

Nombre dérivé

soit [image] une fonction de la variable x, [image] définie autour de la valeur

Le nombre dérivé [image] de la fonction [image] au point [image] est égal à la limite si elle existe (elle peut ne pas exister) lorsque [image] tend vers [image]:

qui s'écrit aussi, d'une manière équivalente,
en posant [image] et

Ce nombre représente la pente de la droite tangente à la courbe [image] en

d [image] est appelé accroissement de la fonction

d [image] est appelé accroissement de la variable

ce qui donne

Fonction dérivée:

La fonction dérivée de la fonction [image] se note [image] . C'est la fonction qui à tout [image] associe la valeur A du nombre dérivé de la fonction [image] en ce point.

On note (d'une façon pas très rigoureuse mais bien pratique):

On peut donc écrire

Fonction primitive:

C'est tout simplement la réciproque de la fonction dérivée.

Si [image] est la fonction dérivée de [image] alors [image] est la primitive de

qui découle directement de la relation précédente.

Si on considère la fonction primitive de la fonction quelconque f et non plus de f' on utilisera la notation classique:

Il restera alors à calculer cette primitive à priori inconnue.

Voilà pour les définitions, maintenant on va calculer quelques fonctions dérivées et primitives pour se faire la main.

Et puis la notion de primitive va nous permettre d'inventer la fonction logarithme népérien qui elle même nous amènera à découvrir sa réciproque, la fonction exponentielle de base "e". Et cette dernière est INCONTOURNABLE en physique et en électronique. Donc on y coupe pas, c'est un cheminement, une suite logique.
Et avec la fonction exponentielle on découvrira une nouvelle façon de noter et manipuler les nombres complexes. Et ce n'est qu'à ce moment là que nous pourrons commencer à faire de l'électronique, de la vraie!
Avec tout ces outils et un petit peu de transformées de Fourier on s'attaquera à l'analyse harmonique. Et puis un jour on voudra percer le mystère des transitoires ce que nous ferons avec quelques équations différentielles. C'est alors que nous apprendrons à remplacer le calcul différentiel par des calculs algébriques grâce à la transformée de Laplace.


Intégration

Intégrale définie

Je vous propose une approche intuitive de la notion d'intégration et du lien entre fonction primitive et fonction dérivée, sous forme graphique puis analytique.

Soit donc dans un repère cartésien orthonormé la courbe représentative d'une fonction [image] presque quelconque, plus précisément d'une fonction de la variable [image], définie et continue entre les valeurs [image] et

Considérons la surface Sba (en jaune) située sous la fonction, c'est à dire l'espace délimité par la courbe représentative de cette fonction, l'axe des abscisses et les droites parallèles à l'axe des ordonnées délimitant l'intervalle des [image] compris entre [image] et

Cette surface peut être découpée en fines tranches verticales de surface [image] comprises entre les valeurs de [image] et

Considérons une de ces tranches (en orange)

Lorsque [image] tend vers 0 nous écrirons

Lorsque la largeur [image] de la tranche tend vers 0, c'est à dire lorsque [image] tend vers [image] alors [image] tend vers [image] puisque la fonction est continue, et la surface [image] tend vers 0 certes, mais plus précisément vers un rectangle de surface

Nous pouvons écrire:

La valeur de la surface Sba est la somme de toutes ces minces tranches juxtaposées comprises entre [image] et

Si les tranches ont une largeur non nulle est sont en nombre limité, nous pouvons écrire:

Pour une fonction « en escalier » (succession de segments horizontaux) ce calcul peut convenir. Mais pour une fonction continue d'une variable réelle, ce n'est plus le cas. Il faut pousser le raisonnement à sa limite:

Lorsque nous faisons tendre la largeur [image] des tranches vers 0, leur nombre tend vers l'infini, ce qui ne change pas leur somme qui vaut toujours S, mais la précision augmente d'autant plus que nous approchons de cette limite (les « haut » des tranches s'approche de plus en plus d'un segment horizontal, donc la forme des tranches s'approche de plus en plus du rectangle de surface [image] [image] [image] ). Nous utiliserons alors une nouvelle notation, celle de l'intégrale définie:

Remarque: Sba n'est pas une fonction mais une valeur constante.

Intégrale indéfinie et fonction primitive

Considérons maintenant une valeur arbitraire [image] de [image] située à gauche de [image] et définissons une fonction [image] de la variable [image] , qui donne la valeur de la surface sous la courbe pour toute valeur de [image] depuis

De même:

En effet, le deuxième terme de cette avant dernière ligne, soit [image] n'étant qu'une « tranche unique » de surface entre [image] et [image]...

Donc:

La fonction [image] est donc la fonction dérivée de la fonction [image], et donc, réciproquement, la fonction [image] telle que nous l'avons définie plus haut est une primitive de [image] (primitive au sens justement que la dérivée donne la fonction). C'est une primitive au même titre que toutes les fonctions [image] (le terme [image] s'annulant lors de la dérivation).

Remarquons maintenant que la fonction

est également une primitive de [image] et n'en diffère donc que d'un terme

Nous en déduisons que

Il devient ainsi inutile de préciser le point [image] (ou [image] ou autre...) pris comme origine des [image] pour obtenir ces primitives, et on définira l'ensemble des fonctions primitives de [image] avec la notation:

Cette ensemble de fonctions primitives (on dit aussi « classe d'équivalence » des primitives) d'une fonction est aussi appelée intégrale indéfinie de [image].

Calcul de l'intégrale définie à partir de l'intégrale indéfinie:

soit donc une fonction [image] et son intégrale indéfinie

Soit une de ces primitives

Nous avons:

Ce dernier résultat se déduit directement du graphique représentant les surfaces.

C'est un résultat très important qui montre que pour obtenir la valeur de l'intégrale définie entre deux points, il faut calculer la différence des valeurs que prend une primitive (n'importe laquelle) de cette fonction en ces points.

Exemple:

Calculons la valeur de l'intégrale définie

La fonction [image] admet comme primitive [image] +k

il vient:

si toutefois je ne suis pas trompé!

On voit au passage que la terme [image] s'annule, et donc que n'importe quelle primitive de la fonction [image] fait l'affaire.

C'est pratique pour calculer des surfaces, mais pas seulement, des volumes aussi, des distances parcourues en chute libre, et... des intégrales de Fourier d'un signal périodique et autre transformées de Laplace.
Nous verrons cela prochainement.


Fonction Logarithme Népérien

Définition

La fonction logarithme népérien (ou logarithme de base [image]) est la primitive de la fonction [image] qui s'annule pour

Propriétés

par définition:

soit [image] un nombre réel tel que [image] on calculera [image] et on trouvera

retenons que:

e est un nombre irrationnel qui vaut 2,71828.... voir cet article.
Il a un développement en série assez simple qui permet de la calculer avec autant de décimales que l'on veut. Nous verrons ça plus tard.

Tracé de la fonction y=ln(x) dans un repère orthonormé:

 (courbe tracée avec le logiciel libre kmplot sous linux,
fonction ln et pas log qui est le log décimal pour ce logiciel)

La courbe passe par zéro pour x=1

en violet: ln(e) =1

La fonction tend vers - l'infini lorsque x tend vers zéro.

ln(x) n'est définie que pour x>0

dérivée de

puis que [image] est la primitive de [image] , sa dérivée est la fonction

Tracé de la fonction y=1/x

C'est la pente de la courbe précédente.
Attention: ces deux courbes ne sont pas symétriques!
La fonction réciproque de Log(x) n'est PAS 1/x (c'est exp(x) comme on va le voir prochainement)

logarithme d'un produit, d'une puissance:

Nous utilisons la dérivée d'une fonction composée.

Rappel:

ce qui montre que [image] est aussi une primitive de [image] au même titre que

Calculons la valeur de la constante C

pour [image] nous avons:

donc

Remplaçons C par sa valeur dans le résultat précédent, nous obtenons:

Cette propriété fondamentale des logarithmes qui consiste à remplacer des multiplications par des additions a débouché
  • sur l'impression des tables de logarithmes (petit livre plein de tableaux de correspondance entre les nombres de 1 à 10 000 et leur logarithme, permettant de faire rapidement des multiplications avec 6 chiffres significatifs en virgule flottante. Cherchez "Bouvart et Ratinet" (il doit y avoir également d'autres marques déposées), caractéristique, mantisse, sur le net)

  • sur la fabrication de "règles à calcul" extrêmement pratiques avec un peu d'habitude permettant d'effectuer des multiplications en virgule flottante d'une manière plus rapide (quoi que moins précise, trois chiffres significatifs au maximum) que ce qu'on fait actuellement avec une calculatrice. Voici la mienne:
Remarque: Ces règles à calcul étaient très utilisées dans les années 1960 environ par les ingénieurs électroniciens, mais si je vous parle tant des logarithmes ce n'est PAS pour cette raison. C'est pour permettre de définir logiquement la fonction exponentielle qui est essentielle pour la résolution des équations différentielles et donc la résolution des circuits électroniques.
Principe:

Deux règles, une fixe l'autre coulissante, permettent d'ajouter, en les mettant bout à bout, des longueurs proportionnelles aux logarithmes des nombres inscrits.
Face à la longueur totale obtenue, proportionnelle au PRODUIT de ces deux nombres, on lit le résultat de la multiplication.

Détail:

2 (sur la graduation du haut repérée par la lettre A visible sur la photo précédente) x 1,5 (sur la graduation du bas repérée par la lettre B) = 3 (lu à coté du symbole "pi" sur la graduation du haut)

On peut voir aussi sur cette photo que
2 x 2=4
mais aussi que
2 x 1,2 = 2,4

On peut faire aussi des divisions, calculer des carrés et racines carrées, Log et exp, des sin et cos, tangentes...

Autre propriétés qui découlent directement de la propriété fondamentale

et:

et:

Nous allons maintenant nous intéresser à la fonction réciproque de la fonction Logarithme népérien,à savoir la fonction exponentielle.
Et nous retrouverons alors les nombres complexes et la trigo. On va bientôt pouvoir appliquer tout ça à l'électronique!


Fonction exponentielle de base e

Définition

La fonction exponentielle de base [image] est la fonction réciproque de la fonction logarithme népérien.

Propriétés

exp(0)=1

Nous écrivons donc en reprenant nos variables habituelles a et b:

d'où découle (je vous le laisse démontrer)

calcul de

cas où a est un entier positif:

cas général ou

or:

donc

donc:

Nouvelle notation de l'exponentielle:

d'où l'écriture:

Rappel des propriétés sous cette forme:

Au fait à quoi ressemble cette fonction exponentielle? La voici:
Wahoouu ça monte vite. Comme le développement... durable ? enfin certains le disent... et voudraient surtout nous le faire croire.

On retrouve bien évidemment:

  • exp(0)=1
  • exp(1)=e=2,71828...

Si on couche le graphique (en inversant x et y), on retrouve effectivement la courbe de la fonction logarithme.

La prochaine fois nous allons calculer la dérivée de cette fonction exponentielle (une petite surprise nous attend...) et nous allons pouvoir étudier notre première équation différentielle. Avec ça nous seront en mesure de calculer la courbe de tension aux bornes d'un condensateur qui se charge au travers d'une résistance. De l'électronique quoi! de la vraie! enfin le tout début...


Dérivée de la fonction exponentielle

dérivée de la fonction réciproque d'une fonction:

Nous allons en effet en avoir besoin pour calculer la dérivée de la fonction exponentielle

définition de la fonction réciproque d'une fonction [image] , notée

soit [image] alors [image] (y)

conséquence:

calculons la dérivée de [image]:

peut s'écrire

est une fonction composée. on sait calculer sa dérivée (voir page sur les dérivées)

attention à ne pas confondre les -1 et les apostrophes!

nous obtenons le résultat:

On retiendra que la dérivée de la fonction réciproque est égale à l'inverse de la dérivée de la fonction.

Remarque mnémotechnique: graphiquement la dérivée en un point de la fonction représente la pente de la courbe représentative de la fonction en ce point. Pour obtenir la fonction réciproque il faut permuter les axes x et y. Il est alors intuitif de voir que la pente au même point de la courbe obtenue devienne l'inverse de la pente de départ.

rappel: dérivée de la fonction logarithme népérien

dérivée de la fonction exponentielle de base

dérivons, sachant que la dérivée de la fonction réciproque est égale à l'inverse de la dérivée de la fonction,
comme nous l'avons vu plus haut sur cette page:

Résultat: La fonction exponentielle est égale à sa propre dérivée.

dérivée de

est une fonction composée. Appliquons le règle de dérivation des fonctions composées:

Rappel:

nous obtenons:


Dérivées des fonctions trigonométriques

Dérivée des fonctions trigonométriques

Rappel de quelques limites dont nous allons avoir besoin:

Si ces deux limites sont évidentes, il n'en est pas de même de

puisque [image] et [image] tentent toutes deux vers 0, leur quotient direct est indéterminé.

On peut toutefois calculer cette limite par la méthode géométrique dite « des aires »

sur cette figure représentant le cercle trigonométrique de rayon unité, nous avons:

Le triangle OAC a comme aire:

Le secteur circulaire OAC (délimité par les rayons OA et OC et l'arc (courbe) AC) a comme aire:

Le triangle OAD a comme aire:

Nous voyons que quel que soit l'angle [image] compris entre 0 et pi/2 (90 degrés), l'aire [image] du secteur circulaire est TOUJOURS plus grande que celle [image] du petit triangle, tout en étant TOUJOURS plus petite que celle [image] du grand triangle.

On peut donc écrire l'inégalité suivante (on appelle cela un encadrement):

Or nous savons que

et donc:

Lorsque [image] nous voyons que

se trouve encadrée entre 1 et 1.

Nous en déduisons bien volontiers, sans qu'un gendarme ne nous y oblige, que

et en prenant l'inverse:

=1

On peut aussi s'en convaincre (mais ce n'est pas une démonstration) en traçant la fonction avec le logiciel libre Kmplot::

Fonction y = sin(x)/x :

De même calculons une autre limite importante dont nous allons avoir besoin:

La démonstration est affaire de cuisine,

sachant que

Nous obtenons un produit de trois facteurs dont les limites respectives sont faciles à calculer:

(1)

donc:

(2)

et:

(3)

Nous obtenons la limite recherchée:

On peut aussi s'en convaincre (mais ce n'est pas une démonstration) en traçant ces fonctions avec le logiciel libre Kmplot:

Fonction [cos(x)-1] / x :

Arrivés à ce stade nous disposons des outils permettant de calculer les dérivées des fonctions trigonométriques:

Ces dérivées nous seront indispensables pour résoudre les équations différentielles du second ordre, ce qui nous permettra de concevoir un étage électronique capable de générer un signal sinusoïdal, à savoir un oscillateur.

Dérivée des fonctions

De même on démontre que:

Voici sur le même graphique, les fonctions sin(x) et cos(x)
Chaque courbe représente la valeur de la pente de l'autre (pour un même x donné, nous électroniciens nous dirions plutôt "au même instant"), ce qui confirme le résultat précédent.


equations differentielles du premier ordre

Equations différentielles du 1er ordre

C'est une équation qui fait intervenir

équation différentielle du premier ordre sans second membre:

Elle est de la forme:

Il s'agit donc de trouver une fonction [image] qui soit solution de l'équation

nous savons que [image] (voir page sur la dérivée de [image])

donc

la fonction [image] est donc une solution de l'équation différentielle en effet:

On vérifie de même que [image] est aussi solution de l'équation

donc:

Toutes les fonctions [image] sont solutions de l'équation différentielle

équation différentielle du premier ordre avec second membre:

C'est le cas général, il s'écrit:

voyons si la fonction [image] est solution?

non, ce n'est pas une solution, toutefois au vu du résultat

on va tenter la fonction

Cette fois ça marche, nous pouvons écrire que les toutes les fonctions:

sont solutions de l'équation différentielle

Comme vous pouvez le voir, lors de la recherche de la solution d'une équation différentielle, on y va parfois à tâtons, mais rassurez-vous, pour les intégrales c'est pire!

Autre remarque: elle est bien utile cette fonction exponentielle, n'est-ce pas? Elle sert à représenter des nombres complexes, à résoudre des équations différentielles...

Dans la plupart des cas rencontrés dans la pratique, il existe des conditions sur la fonction [image] et sa dérivée qui restreignent l'ensemble des solutions à une solution unique.

Nous allons voir cela plus en détail lors du calcul de la charge d'un condensateur par une tension continue à travers une résistance.


Charge d'un condensateur

Soit le circuit ci_contre constitué d'une source de tension continue de valeur E„ d'une

résistance R, d'un condensateur C et d'un interrupteur.

Avant l'instant t=0 on considère que l'interrupteur est ouvert et que le condensateur est totalement déchargé ( [image]).

A l'instant t=0 on ferme l'interrupteur.

Que se passe t-il alors? Puisque [image] la totalité de la tension se retrouve aux bornes de la résistance et un courant s'établit donc avec une intensité égale à

Le condensateur commence donc à se charger, la quantité d'électricité qu'il contient augmente suivant la loi

la tension [image] à ses bornes augmente en proportion, suivant la loi

La tension augmente semble-il proportionnellement au temps.

Seulement ce calcul n'est valable qu'à l'instant

En effet dès que la tension [image] augmente, la tension aux bornes de la résistance, qui est égale à [image] diminue, et par conséquence le courant [image] diminue lui aussi. Et donc [image] augmente moins vite. Et de moins en moins vite...

Comment calculer de quelle manière varie ce courant et cette tension en fonction du temps?

En résolvant une EQUATION DIFFERENTIELLE.

En fait il ne faut pas écrire [image] mais considérer les petites variations de [image] qu'on appellera [image] lorsque le temps augmente d'une toute petite quantité [image] et faire tendre ces quantité vers 0.

on écrira

de même pour la tension en fonction de la charge:

ce qui nous donne:

Nous pouvons également écrire une deuxième équation qui lie tension et intensité (loi d'ohm dans la résistance)

En rapprochant ces deux équations, il vient:

Tiens il y a une fonction [image] (t) et sa dérivée [image] dans la même équation, c'est une équation différentielle du premier degré.

Première méthode:

Ecrivons-la sous une forme plus habituelle:

posons

Résolvons l'équation sans second membre associée:

solution de cette équation sans second membre:

la solution générale de l'équation avec second membre devient:

Il s'agit maintenant de déterminer la valeur de la constante K

pour [image] nous avons:

Or nous avons décidé comme condition initiale que au temps [image] le condensateur était déchargé, donc que

Nous pouvons donc écrire que

donc

La solution particulière de l'équation différentielle devient:

En conclusion:

Voici L'allure de la tension en fonction du temps.

Seconde méthode: intégration directe

Cette méthode est applicable lorsqu'on a affaire à une équation différentielle du premier ordre dite à variables séparables, ce qui est le cas ici (on peut séparer les variables temps et tension de part et d'autre du signe égal)

Repartons de l'équation vue plus haut:

séparons les variables u et t

puis intégrons les deux membres:

l'intégrale de 1/x étant ln(x) il vient:

appliquons les conditions initiales: si [image] alors [image] pour trouver la valeur de

l'équation devient:

Nous trouvons le même résultat, comme c'est bizarre!

APPLICATION PRATIQUE: Oscillateur à NE555


Oscillateur harmonique LC

Oscillateur harmonique

Un exemple classique d'oscillateur harmonique en mécanique est constitué par une masse suspendue à un ressort.

Nous allons étudier son équivalent en électronique: un condensateur préalablement chargé que l'on connecte aux bornes d'une bobine.

Soit donc le schéma constitué par un condensateur parfait (sans pertes ni résistance série) et une self parfaite (bobine constitué par l'enroulement d'un fil de résistivité nulle, supraconducteur, oui c'est ça, et sans perte par rayonnement, un tore, oui par exemple, et sans pertes d'énergie dans le circuit magnétique).

On suppose donc le condensateur préalablement chargé par une tension E, par un moyen qui importe peu et qui n'est pas représenté ici. A l'instant [image] on ferme l'interrupteur. Que se passe-t-il?

La résistance en continu de la bobine étant nulle et le condensateur parfait, on pourrait penser que la fermeture de l'interrupteur va provoquer un court-circuit au conséquences inimaginables sur le plan conceptuel ! Il n'en est rien: en effet dès qu'un courant s'établit, il ne peut le faire, partant de zéro, qu'en augmentant d'intensité. Et cette augmentation de l'intensité, qui n'a justement rien d'un courant continu, provoque une self-induction dans la bobine qui s'oppose à son établissement. L'augmentation de ce courant, et par conséquence l'intensité restera dans des valeurs finies et parfaitement calculables.

C'est ce que je vous propose maintenant: calculer la valeur et l'allure du courant [image] et de la tension [image] en fonction du temps.

(voir également la page sur la charge d'un condensateur où je détaille un peu plus le comportement d'un condensateur)

Concernant le condensateur donc, nous pouvons écrire:

donc

et concernant la self nous avons:

(pas de signe (-) compte tenu du sens du courant que j'ai choisi vers le condensateur)

On obtient:

avec

on pose

Nous obtenons l'équation différentielle du second ordre suivante:

[Note] Je propose ICI sur une autre page de ce site une résolution de cette équation par simulation numérique en 5 lignes de langage C.

dont nous connaissons l'ensemble des solutions:

qui peut s'écrire: (voir ici)

reste à calculer [image] en fonction des conditions initiales, qui sont:

à t=0

A,C et [image] n'étant pas nuls, nous en déduisons que

l'équation devient:

à partir de ce résultat on peut écrire:

L'équation de la tension devient donc:

et celle du courant:

Remarque:

on peut donc écrire [image] sous la forme:

Analyse dimensionnelle:

On vérifie que [image] étant homogène à [image] (et à [image]) , [image] est homogène à [image] donc à

et par conséquent [image] est homogène à [image] donc à

Ces équations un peu « bizarres » donnant l'intensité sont donc homogènes.

Tracé de la tension et de l'intensité en fonction du temps:

 Voici en orange la courbe de la tension, et en bleu celle de l'intensité.

On remarquera que le maximum de l'intensité se produit lorsque la tension est nulle.

L'énergie contenue au départ sous la forme E=1/2C.u² dans le condensateur se retrouve alors dans la self sous forme 1/2 L.i²

Bien entendu dans la réalité les éléments n'étant pas parfaits, il faut tenir compte de la résistance du fil de la bobine, des pertes par rayonnement (qui s'ajoutent à cette résistance). Les oscillations s'en trouvent amorties, et les sinusoïdes voient leur amplitude décroître.
Un nouveau terme apparaît dans l'équation du second degré, comme nous le verrons prochainement.


Impédances complexes de L et C

Impédance complexe du condensateur:

soit [image] (on considère que la phase [image])

Les lois élémentaires de l'électricité donnent:

(la quantité d'électricité (en Coulombs) dans le condensateur est égale au produit de la tension aux bornes par la valeur du condensateur (en Farads))

dérivons cette expression:

or nous savons que

(t est le temps)

donc

en en déduit:

Impédance complexe de la self:

soit [image] (on considère que la phase [image])

Les lois élémentaires de l'électricité donnent:

en en déduit:

Impédance complexe de la résistance:

c'est [image] puisque

Nous voici donc munis des modèles mathématiques des trois composants électroniques passifs linéaires de base.
Ces modèles vont nous permettre de calculer la réponse en régime harmonique. Lorsque les signaux sont périodiques mais ne sont pas sinusoïdaux, nous verrons que nous pouvons les décomposer en une somme de signaux sinusoïdaux avec la transformée de Fourrier.

Le régime harmonique considère la réponse des circuits à un signal sinusoïdal établit (c.a.d d'amplitude constante dans le temps depuis un temps suffisamment long) contrairement au régime transitoire qui considère l'évolution de signaux non périodiques (établissement d'un signal depuis zéro, impulsion...)

Pour calculer le comportement des circuits en régime transitoire nous verrons que nous devrons soit résoudre les équations différentielles qui régissent ces circuits, soit utiliser un outil très puissant que constitue la transformée de Laplace. Ce sera l'objet du calcul symbolique. Nous serons alors amenés à calculer l'impédance symbolique des composants qui fera apparaître l'opérateur p (bon je ne résiste pas à vous dire que l'impédance symbolique du condensateur sera 1/Cp histoire de vous laisser entrevoir que ce ne sera pas épouvantablement compliqué après toutefois avoir maîtrisé le principe de la transformée de Laplace, qui n'est pas si simple sur le plan conceptuel).


Equations différentielles du second ordre

Equations différentielles d'ordre 2

Définitions:

On appelle équation différentielle linéaire du deuxième ordre toute équation de la forme:

où [image] sont trois fonctions continues et [image] (la dérivée de la fonction dérivée)

Si u est la fonction nulle, l'équation est dite homogène.

On appelle équation différentielle linéaire homogène du deuxième ordre à coefficients constants toute équation de la forme:

Résolution

Cas simple:

Nous allons tout d'abord traiter le cas particulier de l'équation suivante, ne faisant pas apparaître [image] mais seulement mais seulement la fonction [image] et sa dérivée seconde [image]:

c'est à dire

nous savons que [image] et que

donc

Nous voyons que nous sommes très près du résultat.

Essayons la fonctions composée [image]:

La fonction [image] est donc solution de l'équation différentielle du second ordre

Oui mais... La fonction [image] est aussi solution de cette équation différentielle:

et plus généralement les fonctions

sont donc solutions de cette équation différentielle.

en outre la fonction [image] est donc aussi une solution:

est donc aussi solution de cette équation différentielle.

rappel:

est la forme exponentielle d'un nombre complexe

dont [image] est le module (longueur distance au point 0) et [image] l'argument (l'angle)

avec dans notre cas

Remarques:

-Les électroniciens rencontrerons plus précisément [image] avec

-La fonction [image] est équivalente à

avec

(voir la démonstration)

-L'ensemble des solutions de l'équation différentielle [image] représente donc l'ensemble des nombres complexes, c'est à dire le plan complexe. Les mathématiciens diront que l'ensemble des solutions forme un espace vectoriel de dimension deux, un plan vectoriel.

Si on connaît deux solutions qui forment un système libre (toute combinaison linéaire nulle de ces vecteurs implique la nullité des deux coefficients), alors ces deux solutions forment une base du plan vectoriel et la solution générale est la combinaison linéaire des deux solutions qui forment la base:

Dans notre cas, [image] et [image] forment une telle base.

en effet [image] ,

Démonstration:

considérons l'expression

signifie que nous pouvons prendre le cas [image]:

donc [image] implique que

signifie que nous pouvons également considérer le cas [image]:

En conclusion [image] [image] implique que [image] doivent être nuls tous les deux.

et [image] forment donc un système libre.

Et puisque [image] et [image] sont toutes deux solution de l'équation [image], alors ces deux solutions forment une base du plan vectoriel.

La solution générale de l'équation [image] est donc la combinaison linéaire:

Cas général

équation différentielle linéaire homogène du deuxième ordre à coefficients constants

L'équation du second degré:

est appelée équation caractéristique de l'équation différentielle homogène.

Soit [image] le déterminant de l'équation caractéristique

Trois cas se présentent:

  1. :l'équation caractéristique admet deux racines réelles distincte

    alors:

  2. l'équation caractéristique admet une seule racine réelle (dite « double »)

    alors:

  3. l'équation caractéristique admet deux racines complexes distinctes et conjuguées [image] et

    alors: (une sinusoïde croissante ou décroissante)

Développons le cas 3:

racines de

racines complexes de l'équation caractéristique:

posons

Les solutions de l'équation différentielle [image] forment la combinaison linéaire suivante

autre forme équivalente:

———

Prenons

  • (
  • (-j)(

qui sont deux solutions réelles indépendantes comme base de l'espace vectoriel des solutions

La combinaison linéaire formant l'ensemble des solutions devient:

Comme quoi d'une simple égalité entre une fonction et la dérivée de sa dérivée jaillit une oscillation! Que dis-je? un espace vectoriel d'oscillations à croissance exponentielle! Et ça marche! Les oscillateurs sinusoïdaux (dits "harmoniques") sont basés là dessus (mais pas les oscillateurs à relaxation). Nous étudierons ça.


Oscillateur harmonique RLC amorti

Oscillateur harmonique amorti Circuit RLC
Soit le circuit ci-contre,

constitué par un condensateur, une self, et une résistance

On suppose le condensateur préalablement chargé par une tension E, par un moyen qui n'est pas représenté ici. A l'instant [image] on ferme l'interrupteur. Que se passe-t-il?

S'il n'y avait pas l'inductance, le condensateur se déchargerait à travers la résistance suivant une courbe exponentielle décroissante. Mais l'inductance de la self va compliquer un peu les choses. Une oscillation peut apparaître...

Concernant le condensateur donc, nous pouvons écrire:

donc

(1)

et pour la résistance:

Concernant la self nous avons:
 (2)

Loi des mailles appliquée aux tensions:

(4)

Cuisinons tout ça (on pose [image] afin de ne pas traîner cet indice dans toutes les calculs)

(1) et (2) donnent:

(5)

(1) et (3) donnent:

(6)

avec

plaçons (6) et (5) dans (4) pour obtenir une équation différentielle du second ordre:

que nous allons de suite normaliser:

on pose

on remarque au passage que:

Notre équation différentielle s'écrit alors:

son équation caractéristique est la suivante:

dont le voici le déterminant:

Pour la suite, certaines démonstrations ont été faites sur ma page équations diff du deuxième ordre

Cas où m>1

Les racines de l'équation caractéristique sont réelles et valent:

La solution de l'équation différentielle est alors de la forme:

Le condensateur se décharge suivant une exponentielle décroissante, sans oscillations.

Cas où m<1

Les racines de l'équation caractéristique sont imaginaires et conjuguées:

La solution de l'équation différentielle est alors de la forme:

En cuisinant un tout petit peu plus et en tenant compte des conditions initiales, on trouve les valeurs de [image] et de [image]:

condition initiale: à t=0,

On calcule également:

)

D'où l'équation de la tension [image]:

En particulier pour [image] nous vérifions:

Voici le tracé de la fonction u(t)

Remarque: j'ai un doute sur le fait que la sinusoïde parte sur son maximum. A vérifier.

La tension vue à l'oscilloscope


Filtre RC passe bas

Filtre RC - passe bas d'ordre 1

Calcul de la fonction de transfert:

soit

Si la sortie n'est pas chargée (aucune charge connectée en sortie, ou une charge de très grande impédance qui ne perturbe pas le filtre) le courant [image] est le même dans la résistance et le condensateur. De ce point de vue, ces deux éléments sont connectés en série et dans ce cas on peut ADDITIONNER leurs impédances complexes afin de connaître l'impédance équivalente vue de l'entrée qui est donc égale à

On peut alors calculer le courant [image] en fonction de la tension appliquée

La tension de sortie du filtre, [image] qui est la tension aux bornes du condensateur, est égale au produit de ce courant par l'impédance complexe du condensateur:

La fonction de transfert complexe T du filtre est égale au rapport de

Afin de simplifier grandement les formules, pose

C'est ce qu'on appelle normaliser les formules, qui deviennent universelles pour un type donné de circuit, les valeurs des composants n'apparaissant plus directement.
Remarque: on peut vérifier que RC est bien homogène à un temps, et 1/RC est bien homogène à une fréquence (l'inverse d'un temps)

Nous obtenons:

Dans la fonction de transfert complexe il apparaît ω mais pas ω² ni des puissances supérieures de ω, c'est pour cela que cette fonction est dite du premier ordre.

Module de cette fonction de transfert:

rappel:

si

alors module

argument

Tracé du module de la fonction de transfert - échelles linéaires:

 En abscisses ω/ω 0

pour ω/ω0 =1 on lit T=0.707... (voir pourquoi ci-dessous)

Cette courbe de réponse se trace habituellement avec une échelle logarithmique pour ω/ω0, sur laquelle apparaissent de nouvelles propriétés (droite, pente -6dB/ octave = -20dB / décade, au delà de la fréquence de coupure)

Je publierai ça prochainement.

On voit pourquoi ce filtre est appelle filtre passe-bas.

Fréquence de coupure à -3dB:

pour [image] nous avons:

Calcul du gain en tension (ici = atténuation) pour

Rappel: par définition le gain en tension est égal, en décibels, à

on vérifie que [image] et donc

Argument de la fonction de transfert:

Voici maintenant les courbes 20 Log 10 (T) avec échelle logarithmique pour la fréquence réduite (ω/ω0 en x) et échelle de tracé linéaire pour y, mais comme on trace 20 Log 10(T), cela revient à tracer T (sur l'axe Y) en échelle logarithmique également.

C'est ce qu'on appelle le DIAGRAMME DE BODE:

La pente de la courbe au delà de la fréquence de coupure ω =ω0
est égale à -20dB par décade.

Ce tracé a été effectué avec le logiciel libre GNUplot.

En voici le listing:

#courbe filtre RLC passe bas du premier ordre

set samples 1000
set xrange [0.01: 200]
set yrange [-50: 5]
set logscale x
set grid
f1(x)=20*log10 (1/sqrt( 1+x**2))
plot f1(x) with lines lt 3

En conclusion, une seule formule, la fonction de transfert complexe, nous renseigne à la fois sur l'amplitude et sur la phase du signal de sortie en fonction de la fréquence.


Filtre RLC du second ordre

Filtre passe-bas du second ordre

Calcul de la fonction de transfert:

Si la sortie n'est pas chargée, le courant [image] est le même dans les trois éléments en série R, L et C

Le courant complexe est donc:

et la fonction de transfert complexe:

on pose

Pourquoi? afin de s'affranchir des valeurs particulières de R, L et C et donc d'obtenir une formulation générale, on dit aussi normalisée.

  • (mais aussi de résonance, suivant la valeur de m)
  • est appelé le facteur d'amortissement

La fonction de transfert complexe s'écrit alors (sachant que [image])

En effet, (histoire de ne rien laisser dans l'ombre, des raccourcis un peu rapides sont parfois décourageants):

Nous allons maintenant tracer la réponse en amplitude en fonction de la fréquence de ce filtre, c'est ce qu'on appelle le diagramme de Bode. C'est la courbe du module (au sens vu pour les nombres complexes) de la fonction de transfert. Calculons donc ce module:

Posons

Le module, qui est égal à la racine carrée de la somme des carrés de la partie réelle et de la partie imaginaire, voir les pages sur les nombres complexes, (et Pythagore) est donc:

Voici cette courbe de réponse en échelles linéaires:

Les différentes courbes correspondent à différentes valeurs de la constante m:

couleur | m
bleu | 0,25
vert | 0,45
violet | 0,707 (1/2 racine de 2)
jaune | 1
orange | 1,5
rouge | 3

En abscisses, x=ω/ω0
Rappel: ω (pulsation)= 2 pi * f (fréquence)
Pour les faibles valeurs de m on a affaire à un circuit résonnant... qui résonne, l'amplitude de sortie devient supérieure à celle d'entrée pour ω=ω0.

Voici maintenant les courbes 20 Log (T) avec échelle logarithmique pour la fréquence réduite (ω/ω0 en x) et échelle de tracé linéaire pour y, mais comme on trace 20 Log(T), cela revient à tracer T (sur l'axe Y) en échelle logarithmique également.

C'est ce qu'on appelle le DIAGRAMME DE BODE:

 Les différentes courbes correspondent à différentes valeurs de la constante m:

En abscisses, x=ω/ω0 en échelle log
En ordonnées 20 Log (T)

On constate qu'au delà de la fréquence de coupure, la pente des courbes est de -40dB / décade

D'une manière générale les pentes obtenues sont de 20*n dB/décade, n étant l'ordre du filtre.

Voici le listing pour le tracé avec GNUplot:
set samples 1000
set xrange [0.01: 200]
set logscale x
set grid
f1(x)=20*log10 (1/sqrt( (1-x**2)**2 +(0.15*x)**2))
f2(x)=20*log10 (1/sqrt( (1-x**2)**2 +(0.3*x)**2))
f3(x)=20*log10 (1/sqrt( (1-x**2)**2 +(0.707*x)**2))
f4(x)=20*log10 (1/sqrt( (1-x**2)**2 +(1*x)**2))
f5(x)=20*log10 (1/sqrt( (1-x**2)**2 +(3*x)**2))
plot f1(x) with lines lt 1 ,f2(x) with lines lt 2 ,f3(x) with lines lt 3 ,f4(x) with lines lt 4 ,f5(x) with lines lt 5


Circuit RLC bouchon

Circuit RLC // alimenté en courant

Soit le circuit suivant, aussi appelé circuit bouchon, alimenté en courant (par exemple par le circuit collecteur d'un transistor).

Calculons la tension [image] en fonction du courant

avec les impédances complexes:

on pose:

ce qui donne:

ainsi que:

Nous replaçons ces résultats intermédiaires dans la formule de la tension:

Calcule de la fonction de la fonction de transfert T=v/Ri :

C'est la fonction de transfert d'un filtre de bande.

Calcul du module:

posons

Voici le diagramme de Bode de la fonction:

 En abscisses, x=ω/ω0 en échelle log
En ordonnées 20 Log (v/Ri)
Les pentes de part et d'autre de la résonance sont de 20dB/décade.
Les différentes courbes correspondent à différentes valeurs de m.
Plus m est petit, plus la bande passante se rétrécit.
Voici le listing pour le tracé avec GNUplot:
set samples 1000
set xrange [0.01: 200]
set yrange [-60: 5]
set logscale x
set grid
m1=0.1
m2=0.5
m3=2.5
m4=10
m5=50
f1(x)=20*log10 (2*m1*x/sqrt( (1-x**2)**2 +(2*m1*x)**2))
f2(x)=20*log10 (2*m2*x/sqrt( (1-x**2)**2 +(2*m2*x)**2))
f3(x)=20*log10 (2*m3*x/sqrt( (1-x**2)**2 +(2*m3*x)**2))
f4(x)=20*log10 (2*m4*x/sqrt( (1-x**2)**2 +(2*m4*x)**2))
f5(x)=20*log10 (2*m5*x/sqrt( (1-x**2)**2 +(2*m5*x)**2))
plot f1(x) with lines lt 5 ,f2(x) with lines lt 2 ,f3(x) with lines lt 1 ,f4(x) with lines lt 4 ,f5(x) with lines lt 3

Calcul de la partie réelle et de la partie imaginaire de la fonction de transfert T=v/Ri
en vue de tracer le diagramme de Nyquist:

posons

Diagramme de Nyquist de la fonction de transfert

C'est la courbe paramétrique de la fonction de transfert dans le plan complexe, avec en abscisses, la partie réelle de la fonction de transfert complexe et en ordonnées sa partie imaginaire, en fonction du paramètre x=ω/ω0

On parcourt les ω croissantes dans le sens horaire.

Remarques:

Les courbes obtenues pour différentes valeurs de k (et donc des valeurs du facteur d'amortissement m) se superposent. Toutefois elles ne sont pas identiques, elle diffèrent par leur graduation en ω.

pour [image] on obtient [image] ce qui signifie qu'à la fréquence de résonance le circuit se réduit à la seule résistance R et que pour cette fréquence la tension est en phase avec le courant.

Si R est très grand la tension à la fréquence de résonance le sera également.

On peut calculer une équivalence entre cette R en parallèle sur la self sur notre schéma et la résistance série de la self. R=r (1 +Q²)

Cette courbe a été tracée avec le logiciel libre Open Source Kmplot pour Linux.

Les équations figurant sur cette page ont été écrites avec le logiciel libre OpenSourceGNU TexMacs Editor sous Linux Ubuntu.


Filtre RC en pont de Wien

 Ce filtre est constitué par deux résistances de même valeur et deux condensateurs de même valeur.

Calcul de la fonction de transfert:

(1)
(2)
(3)
(4)

Remplaçons [image] et [image] par leur valeur dans (4):

(5)

plaçons (5) dans (1):

cuisinons le tout:

et nous obtenons la fonction de transfert complexe:

Posons

On remarque immédiatement que la partie imaginaire s'annule pour

et que

Module de la fonction de transfert:

Graphe de ce module en coordonnées linéaires

Diagramme de Bode de ce module

En abscisses, x=ω/ω0 en échelle logarithmique
En ordonnées 20 Log (T)
Les pentes de part et d'autre de la résonance sont de 10dB/décade.

C'est moins sélectif qu'un circuit LC mais en contre-partie on peut facilement obtenir une fréquence de résonance extrêmement basse (quelques hertz voire moins)

Cette coube a été tracée avec le logiciel libre open source GNUplot sous Linux.

Calculons la partie réelle et la partie imaginaire de la fonction de transfert de façon à tracer le diagramme de Nyquist:

Diagramme de Nyquist de ce module

C'est la courbe paramétrique de la fonction de transfert dans le plan complexe.

En abscisses, partie réelle de la fonction de transfert complexe.

En ordonnées partie imaginaire de la fonction de transfert complexe.

en fonction du paramètre x=ω/ω0

On parcourt les ω croissantes dans le sens horaire.

On retrouve la valeur réelle (la courbe coupe l'axe des x) T=1/3 à la fréquence de résonnance.

Cette courbe a été tracée avec le logiciel libre Open Source Kmplot pour Linux.

Nous allons adjoindre un amplificateur opérationnel à ce filtre pour réaliser un oscillateur histoire de confronter la théorie à l'expérience...

Les équations figurant sur cette page ont été écrites avec le logiciel libre OpenSource GNU TexMacs Editor sous Linux Ubuntu.


Oscillateur à pont de Wien

Conception d'un oscillateur sinusoïdal:

Nous avons vu qu'un signal sinusoïdal peut apparaître dans un circuit RLC (parfois appelé circuit oscillant pour cette raison) mais ce signal est éphémère, son amplitude décroissant l'énergie se dissipant bien vite dans la résistance R inévitable. L'idée vient alors d'amplifier ce signal et de le réinjecter dans le circuit afin d'entretenir les oscillations. Cette idée est la bonne, le circuit obtenu fonctionne tout à fait, à condition de respecter le « critère de Barkhausen ».

Soit donc le schéma suivant, constitué par la mise en série d'un filtre de fonction de transfert complexe [image] et d'un amplificateur de fonction de transfert [image], le tout rebouclé sur lui même.

Nous pouvons écrire:

donc:

Cette équation admet deux solutions:

  • soit (
  • soit

C'est évidemment le deuxième cas qui nous intéresse pour constituer un oscillateur.

Il faut calculer l'amplificateur et le filtre sélectif de telle sorte que A.B =1 ne soit réalisé que pour une seule fréquence, celle que nous voulons produire.

sont des fonctions de transfert complexes, [image] impose l'égalité des modules et des arguments.

Rappel: Le module de 1 c'est...1 et l'argument de 1 c'est 0

Donc le module du produit [image] doit être égal à 1, et l'argument nul.

Si le module du produit [image] est inférieur à 1, l'amplitude de l'oscillation ne pourra se maintenir, elle diminuera jusqu'à disparaître.

Au contraire si le module du produit [image] est supérieur à 1 pour l'amplitude augmentera jusqu'à saturation de l'étage amplificateur.

La condition sur l'argument déterminera la fréquence de l'oscillateur.

Réalisation pratique d'un oscillateur à pont de Wien:

posons

(ce R est différent du R de la partie filtre...)

calcul de l'amplification en tension:

L'étage n'est pas inverseur, l'amplification en tension fait apparaître un rapport de résistances, pas d'éléments réactifs, elle est dont réelle et positive.

Calcul du filtre RC en pont de Wien

nous avons déjà étudié ce filtre ici et trouvé:

avec

La partie imaginaire s'annule pour [image] et le module de T vaut alors

La condition d'oscillation est alors:

donc

soit

1+
R
R1
= 3

R
R1
= 3 -1 =2

c'est à dire

Ce qui est facile à obtenir en réglant la résistance ajustable

J'ai réalisé CE montage avant de publier cette page, et j'ai mesuré les valeurs de u1, u2 et de la fréquence obtenue, puis comparé le tout aux valeurs théoriques:

Voici les résultats:

R (filtre)=10kΩ
C (filtre)=10nF

 | u1 | u2 | u1/u2 | Fo=ωo/2π
théorique |  |  | 3 | 1591 Hz
mesurée | 178mV | 58mV | 3.06 | 1607 Hz
rapport |  |  | 1.02 | 1.01

Compte tenu de la précision des composants (5%), on peut presque parler de résultat trop beau pour la fréquence!

Arrivé à ce stade, que de chemin parcouru depuis la page expliquant la notion des nombres complexes et celle permettant de calculer cette fonction de transfert grâce à laquelle nous réalisons cet oscillateur dont le fonctionnement nous devient compréhensible. Mais comment arriver au même résultat sans recourir aux mathématiques?
En d'autre termes, l'électronique (tout comme la physique) et les maths font très bon ménage. Tout comme la nature en général comme le faisait très justement remarquer Richard Feynman.


Filtre de Rauch

Rappel:

  • tension différentielle entre les entrées de l'amplificateur opérationnel = 0
  • courants d'entrées de l'ampli OP =0
Nous étudierons le cas où les deux condensateurs ont la même valeur.

Etablissons les 6 équations de base (1 à 6)
 (1)
(2)
(3)
(4)
(5)

Somme des courants entrants au nœud A = nulle:

(6)

Sur cette base nous allons calculer tout le reste:

(1) et (2) ==>

(7)

(6) ==>

(8)

(7) et (8)==>

(9)
(10)
(11)

On multiplie les deux membres par [image] :

(12)

On pose

on pose: 16, 17 et 18:

(16)
(17)
(18)

on obtient:

Occupons-nous de D à présent:

Nous obtenons la fonction de transfert normalisée:

(21)

C'est la fonction de transfert d'un filtre de bande.

Calcul du module:

Posons

pour [image] le module devient

On démontre que la bande passante à -3dB est égale à 2mωo soit 2 / R3.C

Remarques:

si R1>>R2 on peut faire l'approximation R = R2, la fréquence ne dépend plus que de R2 et R3 (et C)
Le gain dépend de R1 et R3,
La bande passante dépend de R3 (et C)
Il est alors pratique de choisir dans l'ordre:
  • La valeur de C en fonction de la gamme de fréquence désirée
  • La valeur de R3 en fonction de la bande passante désirée
  • La valeur de R1 en fonction du gain désiré
  • Puis d'ajuster la fréquence avec R2.
Par la suite on peut ajuster indépendamment la fréquence et le gain.
C'est un montage qui est très utilisé, avec par exemple un ajustable multitours pour R2, permettant de faire varier la fréquence du filtre.
On peut également remplacer R2 par un transistor à effet de champ utilisé en résistance variable, et ainsi faire varier la fréquence avec une tension.

La bande passante peut être très étroite, et la fréquence peut être extrêmement basse, depuis quelques kilohertz jusqu'à quelques hertz voire millihertz, ce qui serait impossible à obtenir avec des filtres passifs LC.

Voici le diagramme de Bode de la fonction T(ω)/T(ωo) (c'est la partie entre crochets du module de la fonction de transfert):

 En abscisses, x=ω/ω0 en échelle log

En ordonnées 20 Log (v/Ri)

Les pentes de part et d'autre de la résonance sont de 20dB/décade.
Les différentes courbes correspondent à différentes valeurs de m.

Plus m est petit, plus la bande passante se rétrécit.

Tracé réalisé avec le logiciel ligre GNUplot.


Série de Fourier

Série de Fourier (1)

Approche graphique

Soit la fonction sinusoïdale:

f(x)= sin(x)

Ajoutons lui la fonction:

g(x)=1/3 sin (3x)

de fréquence 3 fois plus grande et d'amplitude trois fois plus petite

Puis ajoutons:

h(x)=1/5 sin (5x)

Puis ajoutons:

i(x)=1/7 sin (7x)

Puis ajoutons:

j(x)=1/9 sin (9x)

Puis ajoutons:

k(x)=1/11 sin (11x)

etc...

La courbe obtenue s'éloigne de plus en plus de la sinusoïde pour se rapprocher d'un rectangle dont les fronts de montée et de descente sont de plus en plus raides.

Si nous ajoutons des sinusoïdes suivant cette progression, en nombre infini, nous obtenons effectivement une fonction rectangulaire.

On peut obtenir n'importe quelle fonction périodique (rectangle, dent de scie, triangle, etc...) en choisissant judicieusement les coefficients pour les amplitudes et les fréquences.

Réciproquement ont peut décomposer n'importe quelle fonction périodique en une somme de fonctions sinusoïdales de fréquences multiples de celle de la fonction de départ, cette ensemble de fonctions formant ce qu'on appelle un développement en série de Fourier.

Toutefois la fonction de départ doit satisfaire à certaines conditions dites conditions de Dirichlet (fonction définie, périodique, continue ou comprenant un nombre fini de discontinuités.

Nous allons voir de quelle manière on peut calculer les coefficients, connaissant la fonction à obtenir.

page suivante...

Silicium628


Série de Fourier

Série de Fourier (2)

Etude analytique

Nous avons entrevu graphiquement qu'il est possible de décomposer n'importe quelle fonction périodique répondant aux conditions de Dirichlet en une somme (infinie) de fonctions sinusoïdales de fréquences multiples de celle de la fonction de départ, cette ensemble de fonctions formant ce qu'on appelle un développement en série de Fourier. En pratique, on peut se contenter d'une suite finie de composantes pour approcher la fonction avec une précision voulue.

Intérêt du développement en série de Fourier:

Lorsqu'un signal périodique de forme quelconque est appliqué à l'entrée d'un système linéaire, il en ressort déformé si la fonction de transfert complexe n'est pas purement réelle. Mais un signal sinusoïdal pur, lui, ne sera pas déformé, il reste une sinusoïde pure à la sortie, de même fréquence. Cette sinusoïde n'aura pas forcément la même amplitude ni la même phase, mais la fréquence et la forme sont conservées.

Dès lors, le développement du signal en série de Fourier permet d' effectuer les calculs sur des sinusoïdes en les multipliant simplement et séparément par la fonction de transfert complexe du système. Pour connaître le signal en sortie, il suffit d'additionner ces différentes composantes sinusoïdales ainsi traitées.

D'autre part la décomposition des signaux en série de Fourier permet d'obtenir ce qu'on appelle le spectre du signal, formé par l'ensemble des composantes sinusoïdales, et représenté par des raies discrètes situées à des fréquences multiples de la fondamentale, appelées harmoniques. Et la connaissance de ce spectre permet d'évaluer la bande passante nécessaire au système lorsqu'il s'agit de transmettre le signal incident sans déformation.

Le développement en série de Fourier permet également d'analyser les systèmes de modulation et de transmission de données.

En électronique, la distorsion qui résulte de l'atténuation ou de la suppression de certains harmoniques (substantif masculin) de rang élevé est appelée distorsion harmonique.

1Etude analytique:

La décomposition d'une fonction [image] en série de Fourier s'écrit (en prenant t, le temps comme variable, mais ça peut être [image] vaiable d'espace dans le cas de traitement d'images par exemple, ou une autre variable):

étant la période de la fonction

et [image] la " pulsation "

On peut aussi l'écrire sous forme exponentielle complexe:

étant l'imaginaire pur, [image] (le [image] des mathématiciens)

1.1Calcul du coefficient

Commençons par la forme en sin-cos:

Pour le coefficient [image] rien de plus simple, il suffit d'intégrer [image] sur un intervalle égal à une période, tous les termes sinusoïdaux s'annulent, il reste [image] qui est la valeur moyenne de la fonction:

Donc nous obtenons la valeur du coefficient [image]:

J'avoue que j'ai décomposé toutes les étapes rien que pour le plaisir de voir toutes ces belles intégrales! En fait le résultat était évident dès le départ.

Remarque: Le calcul peut se faire sur n'importe quel intervalle de longueur d'une période,

[ [image]] et pas seulement [ [image]]

Précisons le seul point signifiant de ce calcul, à savoir l'intégrale définie de la fonction sinus sur une période:

Pourquoi [image] ?

est ma période;

Dés lors on peut écrire:

Or la fonction cosinus est périodique de période [image] et

ainsi que:

J'ai détaillé ce point parce qu'il sera réutilisé pour le calcul des autres coefficients.

De même nous avons:

Car

1.2Calcul des coefficients et

Pour les électroniciens et autre radio-amateurs, je ne résiste pas à l'envie de dévoiler que nous allons utiliser le principe de la démodulation synchrone pour chacune des harmoniques, en multipliant le signal par une fonction sinus de fréquence n-multiple de la fondamentale, suivie par une intégration. Mais on va le faire mathématiquement:

Rappel:
=

Multiplions donc notre fonction par [image] et intégrons:

On voit immédiatement que le premier terme est nul (voir calculs précédents)

il reste:

Deux cas sont à envisager:

1.2.1Cas

Si [image] alors tout s'annule. En effet on peut poser [image] et [image] et on retombe dans des calculs vu plus haut à savoir que les intégrales sur l'intervalle T de toutes ces sinusoïdes et cosinusoïdes s'annulent.

Si [image] , il n'en va pas de même:

1.2.2Cas n=p:

Donc le fait de multiplier par [image] permet de trouver les coefficients [image] qui valent donc:

Je vous laisse calculer les coefficients [image] en multipliant cette fois par [image] et vous obtiendrez:

1.3Fonctions paires et impaires:

Une fonction [image] est dite paire si

Elle est dite impaire si

(Une fonction peut n'être ni paire ni impaire)

Les fonctions impaires se décomposent en séries de Fourier ne comprenant que des termes en sinus.

Les fonctions paires se décomposent en séries de Fourier ne comprenant que des termes en cosinus plus éventuellement le terme constant.


Série de Fourier

Série de Fourier (3)

Signal carré

Soit la fonction périodique « rectangulaire » (dite aussi « signal carré ») représentée sur la figure suivante.

C'est la fonction que nous avions obtenue lors de notre approche graphique des série de Fourier.

Cette fonction étant impaire ( [image]), elle se décompose en une série de Fourier ne comprenant que des termes en sinus:

La valeur moyenne de la fonction étant nulle, [image] est nul.

Calculons les coefficients [image] en appliquant les résultats obtenus précédemment:

L'intervalle [image] correspond à une période complète.

Calcul de

L'astuce, vous l'aurez remarqué, consiste à scinder l'intégrale en deux parties, pour lesquelles la fonction [image] a une valeur analytique bien déterminée (constante en l'occurrence, 1 et -1). Mais continuons,

sachant que: donc:

Le résultat diffère selon que

en effet:

Cas pair:

Donc il n'y a pas d'harmoniques de rang pair pour cette fonction carrée.

Cas impair:

(n=2k+1)

puisque

Nous obtenons la série de Fourrier suivante, pour ce signal carré:

ou encore:

Remarques:

Le facteur [image] montre que l'amplitude de la fréquence fondamentale est un peu supérieure à celle de la fonction carrée obtenue.

Nous retrouvons bien les amplitudes en 1/n et les harmoniques de rang n impairs uniquement, comme nous l'avions proposé lors de l'approche graphique.

Voici d'ailleurs cette synthèse graphique à laquelle j'ai rajouté une sinusoïde d'amplitude [image] qui vient en effet tangenter le signal carré (elle ne figure bien sûr pas dans la somme).

On remarquera les petites cornes à proximité de la discontinuité de la fonction. On pourrait penser qu'elles disparaissent lorsque le nombre de composantes augmente, il n'en est rien. C'est ce qu'on appelle le phénomène de Gibbs. Voir à ce propos cet article sur Wikipédia:
  • http://fr.wikipedia.org/wiki/Ph%C3%A9nom%C3%A8ne_de_Gibbs

L'ensemble des amplitudes de la fondamentale et des harmoniques en fonction de la fréquence peut être représenté sur un graphique que l'on appelle le spectre en fréquence du signal.

Voici ce spectre (vue d'artiste comme on dit) pour notre signal carré. Les amplitudes décroissent suivant une courbe en 1/f

En musique c'est la forme des signaux sonores et donc le contenu spectral qui constitue le timbre d'un instrument. C'est également ce qui permet de reconnaître les voix, et même ce qui permet de discerner l'information contenue dans le langage parlé, en ce qui concerne l'espèce humaine en tous cas. Les oiseaux quant à eux semblent plutôt utiliser des fréquences relativement pures, mais ô combien variées!

En électronique, l'appareil de mesure qui permet de visualiser ce spectre s'appelle un analyseur de spectre. Il peut être conçu suivant le principe mathématique à la base du calcul analytique des coefficients a et b, à savoir une multiplication du signal par un signal sinusoïdal de fréquence ajustable et connue puis une intégration qui peut être réalisée par un filtre passe bas ou un filtre de bande étroit centré sur la fréquence d'analyse. Un signal wobulé (à fréquence glissante) permet d'obtenir un balayage continu du spectre sur un écran d'oscilloscope. Il est également possible de numériser le signal à analyser et d'effectuer une transformée de Fourier dite "rapide " (FFT) grâce à une astuce conceptuelle. J'y reviendrai mais je voudrais au préalable vous parler de la transformée de Laplace.

Les transformées de Fourier (qui sont une extension des séries de Fourier pour les signaux non périodiques) ne sont pas que fréquentielles, elle peuvent aussi être spatiales, pour le traitement d'images par exemple.

Les transformées de Fourier constituent le domaine de l'analyse harmonique qui est une branche des mathématiques.

Liens externes:
  • http://fr.wikipedia.org/wiki/Séries_de_Fourier
  • http://fr.wikipedia.org/wiki/Analyse_harmonique_(mathématiques)
  • http://fr.wikipedia.org/wiki/Traitement_d'images


Série de Fourier

Série de Fourier (4)

Signal triangulaire

Après le signal carré, analysons maintenant le signal triangulaire suivant:

Cette fonction étant paire ( [image]), elle se décompose en une série de Fourier ne comprenant que des termes en cosinus:

La valeur moyenne de la fonction étant nulle, [image] est nul.

Calcul des coefficients

L'intervalle [image] correspond à une période complète.

Astuce simplificatrice:

Puisque la fonction est symétrique par rapport à l'axe t=0 (elle est paire), on peut calculer l'intégrale définie sur l'intervalle [image] soit une demi période et multiplier par deux le résultat obtenu pour obtenir l'intégrale définie de

Sur la figure ci-dessous, nous avons:

Nous pouvons donc dans ce cas, écrire:

avec [image] pour

en effet (voir la figure pour la détermination de l'équation de cette droite):

Rappel: Intégration par parties:

posons:

si n est impair nous avons:

Si n est pair, le (-1) écrit en violet devient (+1) ce qui annule le coefficient [image] correspondant.

Il n'y a donc que des harmoniques impairs pour ce signal triangulaire.

Le série de Fourier de notre signal triangulaire est donc la suivante:

Voici le graphe de cette fonction synthétisé avec le logiciel libre Kmplot pour Linux

On voit que la série converge très rapidement vers la fonction triangulaire. Il faut dire qu'elle est très proche de la fonction - cosinus...

C'est aussi la raison pour laquelle il est facile d'obtenir un signal (presque) sinusoïdal en "rabotant" un signal triangulaire à l'aide de conposants non linéaires comme par exemple une diode dont on exploite la courbe du courant en fonction de la tension directe au voisinage du coude de conduction. Ce procédé est mis en oeuvre dans certains composants intégrés célèbres "générateurs de fonctions".

Autre méthode de calcul:

Ce signal triangulaire n'est autre que la primitive du signal carré étudié précédemment, et dont nous connaissons la série de Fourier. Et comme une série de Fourier est une somme de termes, rien de plus simple que d'en calculer l'intégrale.

Toutefois ce n'est pas la primitive de n'importe quelle fonction rectangulaire, et certainement pas de celle d'amplitude +/-1 !

La dérivée de notre signal triangulaire (c'est à dire la pente du triangle) doit être égale (par définition) à la valeur crête de la fonction rectangulaire.

La fonction triangulaire, nous l'avons vu plus haut peut s'écrire pour

La dérivée est donc:

Donc notre fonction triangulaire est la primitive de la fonction rectangulaire de valeur crête [image] ce qui aboutit à un calcul nettement plus simple que le calcul direct:

Nous pouvons donc écrire, sachant que

Après ça vous me direz que ce n'est pas beau les Maths ? Mais ce n'est pas tout:

Remarque: calcul de pi

Si on fait ω=0 [image] on obtient

et donc:

c'est à dire:

Ce qui conduit directement à une méthode pour calculer [image]:

Celle-là on ne l'avait pas vu venir, n'est-ce pas?

Mais à propos, est-ce bien exact?
J'ai programmé (vite fait...) une petite application en Pascal (sous le logiciel libre Lazarus (equiv. Open Source de Delphi) pour Linux) qui calcule cette suite en boucle et voici le résultat après l'avoir laissé tourner 15mn sur un Duron 4GHz et effectuer douze millions de pas:(on peut faire beaucoup mieux, j'i mis un timer 1ms pour pouvoir observer le défilement des décimales, c'est amusant...)

Soit 8 chiffres significatifs exacts, sachant que pour obtenir les suivants il suffit de laisser tourner plus longtemps.


Série de Fourier

Série de Fourier (5)

FORME COMPLEXE

Il existe une autre forme de développement d'une fonction en série de Fourier: le développement en série de Fourier complexe,
dite aussi sous « forme exponentielle »

Nous avons vu que lorsqu'une fonction est paire (ou impaire), son développement en série de Fourier réelle ne comporte que des termes en cosinus (ou respectivement en sinus). Toutefois certaines fonctions, bien que périodiques, ne sont ni paires ni impaires, et dans ce cas il y a à la fois des termes en sinus et en cosinus. Il est alors plus simple pour ces fonctions de calculer le développement en série de Fourier complexe. On en déduit ensuite simplement les coefficients de la transformée réelle.

Mais commençons par calculer les coefficients complexes

Procédons d'une manière analogue à celle utilisée pour le calcul des coefficients réel, à savoir l'intégration sur une période du produit de [image] par (en l'occurrence) une exponentielle complexe de la fréquence concernée (avec un petit signe - pour que ça marche du premier coup! ce qui revient en fait à diviser...):

soit donc la période [image] telle que [image] comme vu à maintes reprises.

La somme comprend toutes les fréquences multiples de [image] (c'est à dire les fréquences [image]) alors que nous multiplions l'ensemble par une seule fréquence

or

et en particulier:

Notre intégrale devient:

Donc dans le cas où [image] l'intégrale est nulle.

Mais ce n'est pas le cas si [image] :

cas

Nous en déduisons la valeur des coefficients

Rappelons que

Remarque:

est donc la valeur moyenne de la fonction.

Correspondance entre les coefficients DSF réels et DSF complexes:

DSF réelle | DSF complexe

Nous en déduisons les relations suivantes:

Et dans l'autre sens:


Série de Fourier

Série de Fourier (6)

Développement en série de Fourier complexe

Signal carré

Rappel:

Donc pour [image] impair [image] :

(Pour n pair, tout s'annule).

On remarque que la partie réelle de [image] est nulle, [image] est imaginaire pur, donc le développement en série de Fourier à coefficients réels ne comporte que des sinus, de rangs impairs puisque n est impair.

En appliquant la formule de correspondance entre DSF complexe et DSF réel, nous obtenons:

Nous retrouvons le développement en série de Fourier réel tel qui nous l'avions précédemment obtenu par le calcul direct des coefficients réels:


Le Produit de convolution
(1)

Etude analytique

Avertissement 1.

J'ai voulu alléger au maximum l'exposé afin d'éviter de décourager ceux qui ne sont pas tombés dans la marmite des maths étant petits, afin qu'au lieu de nous abandonner en cours de route ils puissent accéder rapidement à la compréhension des choses et au plaisir que cela procure.

Donc il manque des précisions sur les ensembles de définition des fonctions, les limites de validité, et des notations du style « presque partout » ou « pour presque tout [image] » ainsi que la justification des changements de l'ordre des intégrations par exemple.

Pour approfondir ces points essentiels vous pouvez consulter par exemple les plus indigestes des pages « Wikipédia » qui se veulent exhaustives mais dont le principe de navigation par liens hypertextes aboutit vite à noyer le lecteur.

1Définition

Le produit de convolution de deux fonctions [image] et [image] se note [image] . Il est définit par:

Démonstration. de l'équivalence de ces deux écritures :

posons

et par conséquent :

et réécrivons la première définition:

Cette dernière écriture est équivalente à :

c'est ce que nous voulions démontrer.

Remarque 2. Les variables [image] et [image] sont toutes deux des variables temporelles, elles peuvent être réelles [image] ou même [image] ( [image]) ou complexes [image].

Remarque 3. Le produit de convolution est commutatif

Démonstration :

Puisque la multiplication dans [image] que dans [image], nous pouvons écrire :

ce qui peut s'écrire :

ce qui est aussi, par définition, égal à :

donc :

On démontre tout aussi facilement que le produit de convolution est :

  • distributif
  • associatif

2Propriétés

2.1Elément neutre

Attention : ce qui suit n'est rigoureux que dans le cadre des distributions. L'impulsion de Dirac n'est pas à proprement parler une fonction, mais une distribution.

Soit [image] une fonction et [image] une impulsion de Dirac en [image]. Calculons leur produit de convolution:

vaut [image] pour tout [image] différent de [image] et annule la somme.

pour [image] il reste :

ne dépendant pas de [image] on le sort de l'intégrale :

par définition de la distribution de Dirac.

La « fonction » de Dirac est donc l'élément neutre pour le produit de convolution.

2.2translation d'une fonction

Attention : ce qui suit n'est rigoureux que dans le cadre des distributions. L'impulsion de Dirac n'est pas à proprement parler une fonction, mais une distribution.

Soit [image] une fonction et [image] une impulsion de Dirac en [image]. Calculons leur produit de convolution:

vaut [image] pour tout [image] différent de [image] et annule la somme.

pour [image] il reste :

ne dépendant pas de [image] on le sort de l'intégrale :

par définition de la distribution de Dirac.

Résultat :

Le produit de convolution d'une fonction et d'une « impulsion de de Dirac en [image] » a donc pour effet de translater la fonction de [image].

3Produit de convolution et Transformée de Fourier

3.1Transformée de Fourier d'un produit de convolution :

Soit deux fonctions [image] et [image] dont le produit de convolution est :

Calculons sa transformée de Fourier :

Soit deux fonctions [image] et [image] dont les transformées de Fourier sont (à un facteur multiplicatif près):

Calculons le produit (multiplication) de ces transformées de Fourier :

posons

(et donc [image])

En résumé :

La transformée de Fourier du produit de convolution de deux fonctions est égale au produit (multiplication) des transformées de Fourier de chacune d'elles.

3.2Transformée de Fourier du produit de deux fonctions :

Soit trois fonctions [image], [image], et [image] telles que [image] soit le produit des deux autres :

Calculons la transformée de Fourier de [image] :

La transformée de Fourier de [image] s'écrit :

La transformée inverse de cette transformée redonne [image] , comme nous l'avons vu :

Remplaçons dans (5) [image] par cette dernière expression :

Changeons l'ordre des intégrations et regroupons les exponentielles :

La partie entre crochets [image] n'est autre que la transformée de Fourier [image] de

Le membre de droite représente le produit de convolution de [image] et

En conclusion la transformée de Fourier du produit (multiplication) de deux fonctions est égale au produit de convolution des transformées de Fourier de ces fonctions.


Fonction de Dirac
(1)

Etude analytique

1Définitions

1.1

On appelle fonction (ou plus exactement distribution) de Dirac la fonction [image] :

C'est la limite d'une impulsion rectangulaire d'aire =1 lorsque sa durée tend vers 0 (et par conséquent lorsque sa hauteur tend vers l'infini, ce qui n'en fait pas exactement une fonction). On peut aussi la définir comme la dérivée de la fonction de Heaviside (échelon unité).

1.2

On rencontrera souvent la fonction [image] qui par définition est nulle partout sauf lorsque son argument est égal à [image], donc pour [image], c'est à dire

C'est un « Dirac en [image] » , c'est à dire ailleurs qu'à l'origine.

Remarque:

1.3Dirac comme fonction indicatrice

Considérons maintenant le produit d'une fonction [image] par un « Dirac en [image] »

Comme [image] est nulle partout sauf en [image], on peut écrire que

calculons son intégrale :

or [image] est une constante, c'est la valeur de la fonction [image] en [image], on peut donc la sortir de l'intégrale, il vient, en posant

or nous avons vu plus haut que par définition

Nous pouvons donc écrire que

L'impulsion de Dirac est donc une « fonction indicatrice », c'est à dire qu'elle permet d'isoler la valeur que prend la fonction à un instant [image].

Silicium628


La Transformée de Fourier

La Transformée de Fourier (1)

Etude analytique

C'est une extension des séries de Fourier, mais pouvant s'appliquer à des fonctions non périodiques. Elle permet d'obtenir le spectre (fréquentiel) d'une fonction (qui peut être périodique mais pas nécessairement). Comme je l'ai déjà écrit à propos des séries de Fourier, les transformées de Fourier constituent le domaine de l'analyse harmonique qui est une branche des mathématiques très importante pour les physiciens et les électroniciens, au même titre que les équations aux dérivées partielles. (Voyez comme j'aime parler de ce que je vous présenterai plus tard dès que j'expose une chose...)

Je ne vais pas développer ici toutes les propriétés de la transformée de Fourier (comme la translation, le produit de convolution, de corrélation, la dérivation, la transformée inverse de Fourier, etc...) beaucoup de personnes le font mieux que moi. Je veux aller à l'essentiel : comprendre de quoi il s'agit, d'une manière théorique puis pratique par le calcul des transformées de Fourier sur ordinateur. C'est ainsi que je vous donne un programme graphique en C++ et Qt4 que j'ai écrit sous Linux Mint avec QT Creator, directement calqué sur les équations ci-dessous, qui calcule et trace des TF.

Remarque 1. Nous utiliserons la lettre j pour désigner le nombre imaginaire [image] au lieu de la lettre i afin de ne pas confondre avec l'intensité i(du courant électrique).

1Définition de la Transformée de Fourier:

1.1Domaine général

soit la fonction (pas obligatoirement périodique) de la variable réelle [image] :

sa Transformé de Fourier (de la variable réelle également [image]) sera:

où:

1.2Domaine temporel

C'est celui qui nous intéresse particulièrement, pour le traitement des signaux, en électronique.

Dans le cas où [image] est une fonction du temps, nous écrirons:

Remarque 2. Le coefficient [image] placé devant l'intégrale est arbitraire, cette valeur [image] est souvent choisie afin d'obtenir une symétrie entre la transformée de Fourier et la transformée de Fourier inverse. Ce qui est doit être respecté c'est que le produit de ce coefficient avec celui choisi pour la transformée inverse soit égal à

est la pulsation en radians /s

le [image] de la ligne ci-dessus est la fréquence en Hertz. Ne pas confondre avec la fonction

ici aussi [image] et

On voit donc que la transformée de Fourier d'une fonction appartenant au domaine temporel est une fonction appartenant au domaine fréquentiel. Elle permet d'obtenir le spectre fréquentiel d'un signal.

1.2.1Transformée de Fourier discrète

Le but que je me fixe est d'écrire un programme (sur PC puis que nous adapterons sur un microcontôleur), capable de représenter le spectre d'un signal en temps réel. Cela passera par une transformée de Fourier rapide (FFT = Fast Fourier Transform). Mais procédons par étapes.

Je vais développer le cas où le signal analogique à transformer est au préalable numérisé, c'est à dire rendu disponible (échantillonné) sous la forme d'une suite discrète de valeurs numériques (d'échantillons). Ces échantillons auront été acquis à des instants régulièrement espacés (par la période Te, c'est à dire à la fréquence d'échantillonage [image] )

Nous disposons de N échantillons

prélevés à des temps [image]...

Dans ce cas où l'on a pas une infinité de valeurs infiniment brèves mais une collection de valeurs discrètes, l'intégrale utilisée dans la définition de la transformée de Fourier se transforme en une somme discrète.

Remarque 3. Puisque le nombre d'échantillons est fini, le temps d'acquisition total [image] sera également fini, égale à l'intervalle

La fréquence d'échantillonage est

Comme l'analyse du signal se fera (par le microcontrôleur) en un nombre fini de points dans l'espace des fréquences, en k points, k étant un nombre entier tout comme N.

Pour chacun de ces k points, il faudra calculer la somme [image] de N termes.

On choisit

Le pas d'incrémentation en fréquence sera

les [image] fréquences à explorer sont

elles couvrent la plage qui s'étend de [image] (pour [image]) à (presque) [image] (pour [image])

Comme nous ne disposont pas de la fonction réelle mais seulement de quelques valeurs échantillonées, on ne peut pas obtenir d'informations fréquentielles pour des valeurs de fréquences supérieures à la fréquence d'échantillonnage. Ce qui implique que dans le cas de l'analyse d'une fonction périodique, la fréquence de cette dernière doit obligatoirement être inférieure à la fréquence d'échantillonnage.

Théorème de Shannon:

La fréquence d'échantillonnage doit être >2 fois la fréquence à analyser.

Remplaçons dans la formule précedente, [image] par sa valeur discrète

comme [image] ,

Notre jolie formule devient:

posons :

ce sont les N échantillons du signal.

ce sont les N termes de la transformée de Fourier de ce signal ( puisque [image] )

La transformée de Fourier discrète s'écrit maintenant:

avec

Pour calculer cette transformée de Fourier on doit donc calculer k fois N valeurs de cette formule, soit [image] multiplications de nombres complexes.

Pour pouvoir calculer une exponentielle complexe sur ordinateur, on utilisera une propriété vue précédemment sur ce site :

Rappel de mathématiques:

Les termes de la somme se décomposent chacun en

- une partie réelle (R)

- une partie imaginaire (I)

L'amplitude de la sinusoïde étant le module de ce nombre complexe :

Il reste à calculer le module ce nombre complexe, pour chaque valeur de k :

J'ai écrit un programme en C++ et Qt4 qui calcule et trace cette tranformée de Fourier. Je vous fournis le code source.

Nous étudierons un procédé simple (fenêtre de Hamming) qui permet de diminuer les lobes latéraux (la transformée de Fourier d'une sinusoïde pure allant dans le temps de [image] à [image] est une simple raie pour sa fréquence et 0 partout ailleurs. Nous verrons que le fait d'échantillonner la fonction sur un intervalle restreint donne un résultat plus « étendu » fréquentiellement. Dès à présent je vous invite à consulter la page de Wikipédia concernant le fenêtrage que je trouve vraiment bien faite:

http://fr.wikipedia.org/wiki/Fen%C3%AAtrage

)

Puis il nous restera à tirer parti de simplifications de l'algorithme afin de réduire le nombre de calculs élémentaires d'un facteur 100 (permettant l'implémentation sur un microcontrôleur en vue d'un traitement en temps réel, ce qui constitue un analyseur de spectre).

Le programme en C++ Qt4 est >> ici << .

Copie d'écran du programme en C++ et Qt4:


La Transformée de Fourier Rapide (FFT)

La Transformée de Fourier Rapide (FFT) (2)

La rapidité d'exécution du calcul est essentielle lorsqu'il s'agit de traiter un signal en temps réel. Elle déterminera la fréquence maximale qui puisse être analysée. Repartons de la formulation complexe :

Posons

Comme nous l'avons vu et expérimenté précédemment, l'application directe de cette formulation consiste à faire évoluer les indices n et k de 0 à N ce qui conduit à effectuer [image] opérations ce qui représente vite, même avec des processeurs rapides, un temps de calcul important (plusieurs ms sur un microcontrôleur tournant à 20MHz, limitant la fréquence d'analyse à quelques dizaines de Hz). Mais on peut réduire ce nombre d'opérations en appliquant quelques astuces algorithmiques :

Posons :

1Valeurs remarquables de :

1.1

Démonstration. de (2) :

1.2 pour

Rappels :

Tableau 1.

Démonstration. de (3):

1.3

Démonstration. de (4) :

1.4

Démonstration. de (5) :

1.5

Démonstration. de (6) :

2Algorithme de Transformée rapide

2.1Séparation en deux moitiés :

Séparons les échantillons d'ordre pair et impair, en tenant compte de ce que nous avons vu plus haut, il vient:

Nous voyons que la transformée de Fourier de taille N est devenue la somme de deux transformées de Fourier de taille N/2. Si le calcul de départ prenait [image] opérations, maintenant il ne nécessite plus que [image] soit environ la moitié.

Si N est une puissance de 2, on peut répéter le fractionnement jusqu'à l'obtention d'une somme de base 2, l'ensemble des calculs ne nécessitant plus que [image] opérations ce qui peut être 100 fois moins lourd.

Nous remarquons également que le facteur [image] se retrouve à l'identique dans les termes de rang pair et impair de même ordre et ne sera donc calculé qu'une fois sur deux.

Le facteur [image] qui ne dépend pas de [image] (ni de [image]) (raison pour laquelle on l'a « sorti » de la somme [image]) figurant dans les termes de rang impair, pourra bénéficier de la propriété(4).

L'algorithme le plus célèbre qui en découle est celui inventé en 1805 par Carl Friedrich Gauss pour calculer les trajectoires des astéroïdes Pallas et Juno, puis réinventé en 1965 par James Cooley (IBM) et John Tukey (Princeton) qui l'adaptèrent au calcul sur ordinateur et lui donnèrent leurs noms.

2.1.1transformée de Fourier des échantillons de rang pair :

est la transformée de Fourier d'ordre [image] des échantillons de rang pair.

(F comme Fourier, indice P comme Pair, et indice 2 comme ordre N/2)

Remarque, d'après (5):

Démonstration. de (9) :

2.1.2transformée de Fourier des échantillons de rang impair :

est la transformée de Fourier d'ordre [image] des échantillons de rang impair

remarque, toujours d'après (5) :

La transformée de Fourier complète devient :

Nous pouvons maintenant décrire l'algorithme de Cooley-Tukey qui concrétise les équations qui précèdent. Toutefois toutes les descriptions que j'ai pu voir (en français) de cet algorithme (agrémentés de croquis de « papillons ») m'ont paru claires comme du jus de chique. Je vais donc essayer de rendre la chose limpide et j'avoue que je ne sois par sûr d'y parvenir ! Je n'ai moi-même compris la chose qu'en lisant des travaux parus en anglais.

Je pense que le plus simple consiste à se fixer une valeur de k petite, 8 par exemple, d'écrire dans un tableau les 8 lignes de calculs correspondantes, puis de voir les simplifications qu'on peut y apporter.

soit donc N=8, et N/2=4.

Appliquons le résultat connu (9) : ainsi que (11) :

Les coefficients [image] qui multiplient les seconds termes sont appelés en anglais « twiddle factor » ce qui est assez cocasse surtout si vous le traduisez mot à mot... Nous allons nous en occuper maintenant.

reprenons (14)

avec n = 1, il vient:

Nous pouvons alors diminuer à nouveau le nombre de termes différents: (on fait sauter [image] à [image])

N'apparaissent plus que les transformées de Fourier d'ordre N/2 [image] à [image] et [image] à [image] soit quatre TF de rang pair, quatre TF de rang impair et quatre « facteurs de tripatouilages » ( [image]), ces derniers pouvant être pré-calculés et mémorisés.

Récapitulons afin d'être clair:

c'est une des composantes de la transformée de Fourier que l'on cherche à obtenir. C'est une raie dans le domaine fréquenciel.

c'est une transformée partielle d'indice k calculée sur les échantillons pairs du signal temporel.

Elle nécessite de calculer une somme basée sur tous les échantillons pairs (balayage par [image]).

c'est une transformée partielle d'indice k calculée sur les échantillons impairs du signal temporel.

Elle nécessite de calculer une somme basée sur tous les échantillons impairs.

Les transformées partielles [image] et [image] sont obtenues en prenant successivevent [image] et en balayant toutes les valeurs de [image] (donc tous les échantillons) pour chacune de ces valeurs de [image].

Donc le calcul de chaque valeur de [image] nécessite d'utiliser tous les échantillons [image] (pairs et impairs) du signal au même titre que les transformées partielles.

2.2Représentations graphiques

Voici une représentation graphique de ces calculs. Les moulinettes qui brassent tous les échantillons se situent dans les gros pavés oranges.

Remarquons que les mécanismes de ces deux moulinettes sont identiques, la seule différence se trouve dans les échantillons qu'on leur donne à traiter, pairs pour celle du haut, impairs pour celle du bas.

Remarquons également que celle du haut traite un nombre pair d'échantillons (quatre), on peut donc la remplacer par deux moulinettes traitant chacune la moitié de ces échantillons séparés en échantillons pairs et impairs, leurs sorties une fois multiplexés suivant le même schéma que celui utilisé sur la figure actuelle.

Et la même remarque vaut pour la moulinette du bas.

Allez, hop au boulot, traçons ce nouveau schéma qui devrait nous permettre de diviser par deux le nombre d'opérations mathématiques à effectuer.

Oui mais pourquoi les échantillons qui entrent dans les boites à gauche ne sont plus disposés dans le même ordre? 0, 4, 2, 6 par exemple pour les quatre du haut au lieu de l'ordre naturel des entiers pairs, à savoir 0, 2, 4, 6 ???

Et bien c'est parce qu'il faut renuméroter les échantillons du premier diagramme :

le premier échantillon qui entrait dans la boite était le numéro 0

le second était le numéro 2

le troisième était le numéro 4

le quatrième était le numéro 6.

Ces quatre échantillons étant la totalité de ce qui entre dans la TF, on les renumérote par ordre d'arrivée, puis on prend les deux pairs pour la petite moulinette du haut puis les deux impairs pour la petite moulinette suivante. Les deux pairs par ordre d'arrivée ce sont les num 0 et 4, les deux impairs ce sont les num 2 et 6.

Voilà, je pense que la seule difficulté pour appréhender la recette réside dans ce point. Le reste c'est de la cuisine ordinaire.

Nous pouvons aller encore plus loin en fractionnant les TFR d'ordre N/4 en deux TFR d'ordre N/8 et ne traitant plus chacune q'un seul échantillon.

Qu'avons-nous gagné à fractionner ainsi les transformées de Fourier ? On gagne le fait que les sommes qui brassent les échantillons s'effectuent avec des boucles bien plus petites, ce qui conduit à [image] au total au lieu de [image] opérations (plus les quelques multiplications par les facteurs de tripatouillages...)

Notons qu'avec un N bien plus grand, (mais toujours égal à une puissance de 2) on également multiplier le fractionnement jusqu'à l'obtention de cellules de base, ce qui divise d'autant le nombre d'opérations. Le diagramme devient difficile à tracer, toutefois l'ordinateur n'aura aucun mal à le suivre avec des procédures qui peuvent être récursives, mais pas obligatoirement. Ainsi pour N=1024 on divisera le nombre d'opérations nécessaires (par la partie gauche du diagramme) par... 1024. Mais au total, en comptant les opérations de multiplications par les Wn et les additions, le gain sera moins important.

Remarquons que pour N=8, la TF paire d'ordre N/8 devient:

et la la TF impaire d'ordre N/8 devient:

La somme se réduit ainsi à sa plus simple expression ! (On pouvait s'y attendre, les « moulinettes à échantillons » n'ayant plus alors qu'un seul échantillon à mouliner !! )

Ce qui nous donne au final le diagramme suivant :

... dans lequel les grandes sommes ont totalement disparu.

Rappel :

Les multiplications par les facteurs de tripatouillages (« twiddle factor ») sont donc des multiplications de nombres complexes avec partie réelle et partie imaginaire. On voit qu'il définissent une rotation discrète dans le plan complexe.

Ces facteurs ne seront calculés qu'une fois et gardés en mémoire dans un tableau.

Dans le programme en langage C que je vais vous proposer prochainement, j'ai créé une classe (un objet) « Complexe » pourvue d'un opérateur de multiplication interne. Pour le portage sur microcontrôleur, il sera sans doute plus pertinent de décomposer les multiplications complexes en multiplications réelles effectuées par des fonctions.

Remarque 1. (pouvant être utilisée lors de l'implantation sur microcontrôleur)

Les échantillons sont présentés en entrée suivant l'ordre 0,4,2,6,1,5,3,7. Représentons ces nombres dans un tableau avec leur écriture en binaire puis ces valeurs binaires lues de droite à gauche (inversion des bits):

Nous voyons qu'il faut inverser les bits des nombres entiers naturels écrits en binaire pour obtenir les numéros des échantillons dans l'ordre qui convient au traitement.

Remarque 2. Concernant les « twiddle factor » :

Voici un petit tableau qui repésente les valeurs de twiddle factors pour une TFR avec 16 échantillons (c'est l'équivalent des diagrammes vus plus haut, pour 16 lignes au lieu de 8) :

La seconde colonne indique les numéros d'échantillons à traiter après mise dans l'ordre « bits reverse »

Les colonnes qui suivent donnent les valeurs « k » pour les [image] à appliquer.

On voit vite la logique des opérations: en partant de la droite vers la gauche, il faut prendre les entiers naturels (n), puis une valeur sur deux (soit 2n), puis de nouveau une valeur sur deux (2x2 n)... etc... En numérotant « c » les colonnes de 0 à 3 en partant de la gauche, la valeur des « k » pour la colonne « c » est donc:

avec n = entiers naturels 1, 2, 3...

Et il faut prendre des groupes de N/2 puis N/4 puis N/8... k c'est à dire un nombre [image] de k.

Il fallait préciser tout cela car notre programme traitera 1024 échantillons en dix étapes.

Voici le coeur de ce programme en C++ et Qt4, la fonction « calcul_fourier() » qui parcourt les dix étapes, traite pour chacune de ces étapes les 1024 lignes d'échantillons, c'est a dire réalise les multiplications complexes par les twiddles factors ainsi que les additions en suivant les croisements en « papillons » vus précédemment. Comme vous pouvez le constater cette fonction comme tous le reste de mon programme est commentée en français, c'est pas du luxe !

Et voici une saisie d'écran de son exécution sous Linux Mint:

J'ai écrit une page présentant ce programme, avec accès à la totalité du code source :

  • La Transformée de Fourier Rapide FFT (Programme en C++ et Qt4) .... http://www.silicium628.fr/article_i.php?id=31
L'étape suivante consistera à implanter tout ça sur un microcontrôleur ATmega avec acquisition du signal en temps réel...


La Transformée de Fourier Rapide (FFT)

Transformée de Fourier d'un train de sinusoïdes (3)

Nous allons procéder par étapes : Dans un premier temps nous allons calculer la TF d'un signal périodique infini (théorique donc) sinusoïdal. Ensuite celle d'une "fonction porte " (créneau rectangulaire). Puis nous ferons passer notre sinusoïde par cette porte de durée finie et nous utiliserons ce que nous avons appris du produit de convolution de deux fonctions pour obtenir le résultat : La transformée de Fourier d'un train de sinusoïdes.

1Signal sinusoïdal d'une durée infinie :

Soit la fonction sinusoïdale de fréquence [image] et de pulsation

Rappel :

1.1Calculons sa transformée de Fourier:

1.1.1Pour nous obtenons :

Il s'agit d'une raie spectrale infiniment fine (de largeur nulle) pour la fréquence [image] et d'amplitude infinie : c'est une impulsion de Dirac " située " en [image], c'est à dire

Note 1. La distribution de Dirac, aussi appelée par abus de langage fonction [image] de Dirac, introduite par Paul Dirac, peut être considérée comme une fonction [image] qui prend une " valeur " infinie en 0, et la valeur zéro partout ailleurs, et dont l'intégrale sur [image] est égale à 1 (source Wikipédia). Les électroniciens parlent " d'impulsion de Dirac " ou " d'un Dirac ".

Dans le cas que nous venons de voir, [image] s'annule bien pour [image] , d'où la notation [image].

1.1.2Pour :

Pour toute autre fréquence, lorsque [image] l'intégrale est nulle :

Posons

En effet la valeur moyenne de [image] calculée sur un nombre entier de fois sa période [image] est nulle (les deux alternances de la sinusoïde s'annulent, quel que soit ce nombre).

1.2Résultat :

En définitive, la transformée de Fourier d'une fonction sinusoïdale infinie est nulle partout sauf pour la fréquence égale à celle de la sinusoïde, pour laquelle elle est infinie.

que vous trouverez écrite de la manière équivalente dans les livres de Mathématiques et de Physique :

puisque les mathématiciens utilisent la lettre [image] pour représenter le nombre imaginaire, et la lettre greque [image] (nu) pour la fréquence, sachant que [image]. Je précise tout ça parce que j'ai promis de tout vous démystifier et aussi pour le plaisir de l'écrire...

Cet infini ponctuel peut paraître conceptuellement gênant et donc bien peu raisonnable, mais remarquons que cela provient du fait que nous avons considéré une fonction sinusoïdale qui s'étend dans le temps de [image] [image] à [image] ce qui est également bien peu raisonnable. (Le " Big Bang " à -13,7 milliards d'années, en comparaison, c'est de la rigolade...)

Mais réfléchissons un peu plus avant sur ce point : un signal sinusoïdal (stable) qui s'étendrait dans le temps de [image] [image] à [image] permettrait de connaître sa fréquence avec une précision aussi grande que l'on voudrait, il suffirait d'effectuer la mesure de sa période sur un nombre aussi grand que l'on voudrait d'alternances. Et ainsi nous pourrions effectivement obtenir une largeur de la raie spectrale aussi fine que l'on voudrait.

A l'inverse, un signal sinusoïdal de durée finie (un train de quelques sinusoïdes) aura pour transformée de Fourier une raie d'autant plus large et moins haute que la durée du signal sera brève. La fréquence ne sera connue qu'avec une précision limitée. Mais en contrepartie le train d'impulsions pourra être localisé dans le temps (et/ou l'espace) d'autant plus précisément que sa durée sera brève. cqfd . Nous allons d'ailleurs le faire. Mais le calcul direct est un peu compliqué, il est plus simple de passer par des étapes intermédiaires, à savoir : le calcul de la TF d'une impulsion rectangulaire, puis la TF du produit de convolution de deux fonctions.

2Transformée de Fourier d'une impulsion rectangulaire :

aussi appelée " fonction porte ", " fenêtre rectangulaire [image] ", " fonction projectrice [image] ", " créneau solitaire "...

2.1calculons sa transformée de Fourier :

Rappels :(voir ma page [image] et [image])

Nous voyons apparaitre un sinus cardinal (sinc(x)= [image]) dont voici la courbe :

Remarque 2.

  • Cette transformée de Fourier est réelle (partie imaginaire nulle).

  • La largeur du pic principal est égal à

    c'est à dire,

La largeur (fréquentielle) de la raie est inversement proportionnelle à la largeur temporelle de l'impulsion. Leur produit est constant.

Si l'on augmente la largeur de l'impulsion, la largeur du pic de la TF diminue. Si l'on fait tendre la largeur de l'impulsion vers l'infini, la largeur du pic de la TF va tendre vers zéro, la TF devient une impulsion de Dirac.

Ces fenêtres rectangulaires (ainsi que d'autres plus " arrondies " comme la fenêtre cosinusoïdale, la fenêtre de Hanning, de Blackman, de Gauss, de Kaiser, de Dolph-Chebychev, de Silcium628... hum...) sont très importantes, elles nous serviront à borner un signal de durée " infinie " afin d'obtenir et d'étudier des signaux bien réels de durée finie, fut-elle très grande.

3Transformée de Fourier d'un train d'ondes sinusoïdales

Soit le train d'ondes sinusoïdales de fréquence [image] et de pulsation [image] et de durée

Remarque 3.

C'est le produit d'une fonction sinusoïdale par la " fenêtre rectangulaire " vue précédemment.

Nous avons vu (sur ma page " Produit de convolution ") que la transformée de Fourier du produit (multiplication) de deux fonctions est égale au produit de convolution des transformées de Fourier de ces fonctions

Il en résulte que transformée de Fourier d'un train de sinusoïdes est égal au produit de convolution de la transformée de Fourier de la fonction sinus et de la transformée de Fourier de la fonction porte rectangulaire.

Il se trouve que nous avons déjà calculé ces deux composantes:

Nous avons également calculé le produit de convolution d'une fonction par un Dirac [image], le résultat consiste à translater la fonction de la valeur [image].

Nous obtenons donc comme transformée de Fourier d'un train d'impulsions sinusoïdales :

La figure ci-dessous illustre le décallage en fréquence (la maximum de la courbe est centré sur la fréquence du signal incident, on aurait pu s'en douter !)

Nous avons vu plus haut que si l'on augmente la durée de l'impulsion, la largeur (en fréquence) du pic de la TF diminue (La fréquence devient plus précise).
Voici une animation qui illustre cette propriété :

4Transformée de Fourier d'une impulsion de Dirac

Note 4. Par définition, comme vu plus haut, l'intégrale sur [image] d'une impulsion de Dirac est égale à 1

Il en résulte qu'à la limite, la transformée de Fourier d'une unique impulsion de Dirac est égale à 1, c'est à dire non plus à une raie spectrale de fréquence bien définie, mais à la fonction constante, correspondant à l'ensemble de toutes les fréquences imaginable s'étendant jusqu'à [image] (Hz). Ainsi un train d'impulsions de durée nulle sera exactement localisé dans le temps mais n'aura pas de fréquence déterminée.

Remarque 5.

Il se trouve que ces cas de figure correspondent effectivement au comportement des particules élémentaires (fermions) ou des photons (bosons). En particulier en mécanique quantique on démontre qu'on ne peut pas connaître à la fois la position d'une particule dans l'espace ET son énergie avec une précision absolue.
(Etienne Klein nous fait remarquer très justement, dans une conférence présentée sur ce site, que cette façon de dire la chose présuppose qu'une particule élémentaire EST un corpuscule au sens de la mécanique classique qui baigne dans une onde qui l'accompagne, ce qui constitue un blocage conceptuel, les notions présentées dans les livres de mécanique quantique sont restée figées telle qu'elles étaient au début du 20eme siècle, cent ans en arrière ! En fait la notion de corpuscule ponctuel ayant à la fois une position définie et une vitesse définie mais que la méchante mécanique quantique nous empêcherait de connaître ne correspond à rien !)
Ces particules se comportent plutôt (suivant la façon dont on les observe) tantôt comme des corpuscules dont on peut mesurer la position, tantôt comme des ondes dont on peut mesurer la fréquence et donc l'énergie, et que l'on peut faire interférer et diffracter (on parle à tord de " dualité ondes-particules ")... Elles se comportent donc en fait plutôt comme des " paquets d'ondes ", (des quanta) dont nous venons de décrire la transformée de Fourier.
Etienne Klein nous dit "comme des champs". Alors ondes, champs ? Je vais réfléchir à la question.

En tous cas, moi ce qui m'a toujours paru extrêmement difficile à comprendre dans le formalisme de la "dualité onde-particule" c'est l'annihilation d'une paire électron-positon (et plus généralement d'une particule avec son anti-particule) : que les parties "ondes" se détruisent pourquoi pas, mais que deviennent les parties matérielles "particule" ?
Autre phénomène pour le moins curieux : La radioactivité bêta dans laquelle un neutron se transforme en proton avec émission d'un électron et d'un anti-neutrino. Les neutrons et les protons sont formés de quarks, donc on est pas trop étonné de voir que l'un puisse se transformer en l'autre. Mais l'électron il vient d'où ? C'est une particule élémentaire dit-on, or ni les neutrons ni les protons, ni les quarks en contiennent...
Si les particules ne sont QUE des ondes (ou des champs) alors là oui, je marche !
Et le fait que la charge de l'électron soit exactement (en module) égale à celle du proton ( plus exactement que celles des quartz soit exactement des multiples de e/3 ) ? Avec des ondes (ou des champs) je me sens plus à l'aise !

(Notons qu'elles ont d'autres propriétés qui nous paraissent bien étranges encore, aux noms poétiques dans le cas des quarks).

Et oui la découverte de la structure de l'atome nous à montré que la matière est faite essentiellement... de vide (comme l'Univers) ! Et bien il semblerait que la nature (qui avait soit-disant horreur du vide ) en contienne bien d'avantage encore ! Mais en contrepartie le vide semble bien peu vide !!! Entre les champs, les ondes et les particules virtuelles, il semble bien rempli.

Mais arrivé à ce stade de ma cogitation je dois préciser que tout cela ne me porte absolument PAS à croire en des esprits ou des êtres immatériels, comme nous en abreuvent les religions et les feuilletons TV débiles. L'observation intelligente de la nature nous montre que l'esprit et l'intelligence sont liés à la vie, (même "l'intelligence artificielle" des ordinateurs puisque les ordinateurs sont conçus par des êtres vivants !) et que la vie est une propriété émergente de la matière. Les ondes et les champs, hors de la présence de matière à basse énergie, ne font PAS émerger la complexité nécessaire aux organismes vivants. Donc je ne crois pas en dieu, ni en l'âme, ni aux esprits purs ni à toutes ces fadaises.

Oui mais alors si la matière est faite d'ondes ??? Oui mais des ondes qui se donnent la peine de s'organiser en matière ! ET c'est dans ces conditions particulières seulement que peut émerger la complexité pour autant que l'expérience nous le démontre inlassablement.

Si le sujet vous intéresse, je vous propose de voir des vidéos passionnantes de conférences sur la Mécanique Quantique.
Voir dans la partie "Articles" de ce site.

Remarque 6.

Dans le domaine de l'électronique le fait qu'une impulsion brève soit équivalente à un spectre très large en fréquence (on parle de " bruit blanc ") se rencontre lors du fonctionnement de MOSFET en régime de commutation " à fronts raides " (j'en avais dit un mot à propos des variateurs pour moteurs brushless ainsi que des alimentations à découpage) générant des parasites électromagnétiques. C'est aussi ce qui se produit lors de la manoeuvre d'un simple interrupteur sur le secteur 230V(aidé par de multiples rebondissements des contacts), parasitant la réception radio en modulation AM. Il est curieux de remarquer que pour éviter de produire des parasites on a tendance intuitivement à fermer " rapidement " un contact afin de ne pas faire durer l'opération... mais que plus l'établissement ou la suppression du courant se fait rapidement et plus le spectre des parasites sera large ! (On peut aussi remarquer que, dans le cas d'un interrupteur mécanique, plus on rapproche rapidement les contacts, plus on " cogne fort " et plus les rebondissements seront importants. Enfin jusqu'à un certain point... En cognant vraiment très fort, on obtient un plasma de quarks et de gluons lors du choc frontal des murs gluoniques formés pas les condensats de verre de couleur se déplaçant à des vitesses relativistes. Il faut juste un LHC pour faire ça : voir ici et là ).

Toutefois il ne faut pas oublier qu'au tout début de la radio (1887), les premiers émetteurs furent des émetteurs à étincelles mettant à profit la génération d'ondes électromagnétiques par des commutations brèves. Mais les émetteurs à étincelles furent vite abandonnés car produisant des signaux occupant des largeurs de bande très conséquentes.


Calcul de l'atome d'hydrogène

Calcul des niveaux d'énergie dans l'atome d'hydrogène
par Silicium628

Rien de moins.
Nous calculerons au préalable l'altitude de l'orbite géostationnaire puis nous démontrerons la seconde Loi de Kepler pour nous faire la main.

RAPPEL DE CINÉMATIQUE

Vitesse et accélération d'un point matériel dans un plan

Soit M un point matériel se déplaçant dans un plan muni d'un de repère orthonormé [image] (en bleu)

Associons au point M le vecteur OM de module

est appelé le « rayon vecteur »
Ajoutons (en vert) le repère cartésien orthonormé tournant [image] tel que [image] soit à tout instant colinéaire avec le rayon vecteur (radial) et [image] perpendiculaire au rayon vecteur (ortho-radial) (certains parlent de coordonnées polaires, mais ces dernières définissent plutôt la position avec un angle et une distance).

Remarque: On notera les dérivées avec un point au dessus, ex:

Relations entre les deux systèmes de coordonnées:

Nous en déduisons que:

démonstration:

Nous en déduisons également:

démonstration:

Calculons l'expression de la vitesse:

Calcul du vecteur vitesse:

Calcul du vecteur vitesse directement dans le repère tournant:

Calcul de l'accélération

Cas où et Cte

Dans le cas où le rayon vecteur est de longueur constante (le point matériel suit une trajectoire circulaire) et la vitesse de rotation est constante, nous avons:

Cte
= 0

ce qui donne

L'accélération est alors radiale (la composante tangentielle suivant [image] est nulle) et son module est de valeur bien connue [image] le signe (-) indiquant qu'elle est dirigée en sens contraire de [image] , c'est à dire vers l'intérieur de la trajectoire (vers le centre du cercle), elle est dite centripète.

C'est à peu de chose près ce qui se passe pour les satellites géostationnaires.

APPLICATIONS

I - Calcul de l'altitude de l'orbite géostationnaire:

Un satellite géostationnaire de masse [image] décrivant une orbite circulaire de rayon [image] est attiré par la Terre de masse [image] avec une force [image] (son poids)

n'étant pas la hauteur du satellite au dessus du sol (l'altitude) mais sa distance par rapport au centre de la Terre.

est la constante de gravitation universelle

Cette force dirigée vers le centre incurve sa trajectoire, qui sans cela serait une ligne droite. Si bien que son mouvement est accéléré suivant le vecteur [image] dont on vient de calculer l'expression.

La loi fondamentale de la dynamique ( [image]) nous donne:

De ces deux équations nous déduisons:

Nous voyons déjà que la masse [image] du satellite n'intervient pas dans le calcul

Remarque: est connu puisque le satellite restant toujours à la verticale d'un même point de l'équateur fait un tour par 23h56'. (24h00 par rapport au Soleil, mais 23h56 par rapport aux étoiles dites « fixes » durée du jour sidéral soit 86164s)

de dimension

de dimension

kg de dimension

Vérifions l'homogénéité de la formule avant de nous lancer dans le calcul numérique:

et [image] (également), la formule est homogène du point de vue de équations aux dimensions. On peut donc utiliser la calculatrice:

Soit 42 167 km du centre de la Terre.

Soustrayons les 6378 km du rayon équatorial pour obtenir l'altitude:

42167 - 6378 = 35789 km

Je lis ici et là 35784 km... je vous laisse trouver où se cachent les 5 km d'écart...

II - Démonstration de la seconde loi de Kepler

"Le rayon vecteur qui lie une planète au soleil balaie des aires égales en des temps égaux".

Kepler l'a constaté en analysant les données astronomiques recueillies grâce à l'observation par Tycho Brahe et en a déduit que le soleil exerce une force d'attraction centrale sur la planète.

En voici la démonstration inverse à partir des lois de la dynamique.

Considérons le cas d'un objet de masse [image], une planète, une comète ou un astéroïde par exemple, passant dans le champ d'attraction d'un objet de masse [image] beaucoup plus importante que [image], une étoile par exemple. Considérons [image] comme immobile et plaçons la en O de notre graphique, liée au repère cartésien orthonormé [image].

La masse [image], quelle que soit sa vitesse au départ et la direction de sa trajectoire est soumise à une force unique due à l'attraction gravitationnelle que [image] exerce sur elle. Les lois de la physiques démontrables en laboratoire à notre échelle nous indiquent que cette force est appliquée sur [image] et est dirigée dans la direction de [image]. On dit qu'elle est « centrale ».

Elle a pour valeur:

étant la distance séparant les deux masses et [image] la constante de la Gravitation Universelle.

Si nous représentons cette force dans le repère [image], nous voyons que le fait que la force soit centrale implique que la composante suivant [image] est nulle.

On peut donc écrire:

Cette force exercée sur la masse [image] provoque son accélération

étant un scalaire, les vecteurs [image] et [image] sont colinéaires, [image] a tout comme [image] sa composante suivant [image] nulle.

Notons au passage que [image] dépend de [image] et de [image] mais pas de [image]. C'est ce qu'on nomme « l'accélération de la pesanteur »

Nous avons d'autre part calculé plus haut la valeur de [image] pour un point matériel en déplacement:

En égalant ces deux expressions nous obtenons:

Il en résulte deux égalités distinctes, une concernant la composante [image] et l'autre la composante

La première égalité nous a servi à calculer la taille de l'orbite d'un satellite en fonction de la masse centrale et de la période de révolution.

C'est maintenant à la deuxième égalité que nous allons nous intéresser:

C'est une équation différentielle à variables séparables:

Donc [image] est inversement proportionnel à [image] ² , voyons la conséquence que cela implique.

Calculons l'aire balayée par le rayon vecteur lorsque l'objet se déplace entre les points A et B de sa trajectoire:

Si on considère un déplacement très petit, la longueur de la portion de trajectoire AB peut être confondue avec la longueur de l'arc AC centré sur le point d'attraction O.

Cette longueur a pour valeur:

Les points B et C peuvent êtres confondus, la surface [image] balayée vaut donc:

Et puisque nous avons trouvé que [image] , il vient:

Intégrons pour trouver l'expression de l'aire en fonction du temps:

La surface balayée par le rayon vecteur est donc proportionnelle au temps.

Nous obtenons la seconde Loi de Kepler qui dit que les surfaces balayées en des temps égaux sont égales.

Nous sommes partis de la simple hypothèse que la force est centrale pour arriver à cette conclusion. On pourrait donc penser que c'est un effet de la force d'attraction. Mais que se passerait-il si en O il n'y avait pas de masse attractive? On considère par exemple un astéroïde qui passe par là, à des millions de km, mais on « supprime le Terre » et, à la place, on dispose juste un petit télescope... et bien la composante [image] qui était nulle serait tout aussi nulle, et le calcul serait exactement le même, la surface balayée par le rayon vecteur serait proportionnelle au temps bien que l'astéroïde filerait tout droit. (Enfin, sur une géodésique de l'espace-temps me dit Albert). Et il en serait de même de n'importe quel corps se déplaçant en ligne droite observé de n'importe que point de l'espace.

Donc la seconde Loi de Kepler est une conséquence de l'absence d'effet de la masse centrale sur l'axe ortho-radial .

III - Calcul des niveaux d'énergie et spectre de l'atome d'hydrogène

Nous allons faire le calcul sans utiliser l'équation de Schrödinger (voir Bibliographie au bas de cette page). Le calcul que nous allons faire tiendra toutefois compte de la dualité onde-particule (thèse de Louis de Broglie en 1924, qui lui valu le prix nobel en 1929) qui associe à l'électron une onde de fréquence [image] fonction de sa quantité de mouvement tout en considérant encore l'électron comme une particule ponctuelle soumise à une force centrale et en lui appliquant les lois de la dynamique classique.

C'est donc une approche intermédiaire entre l'électrodynamique classique et la mécanique quantique.
C'est l'approche de Bohr qui eu l'intuition que l'onde associée à l'électron sur son orbite doit être stationnaire, c'est à dire que la longueur de l'orbite doit être un multiple entier de sa longueur d'onde [image] , [image] étant la vitesse de l'électron. Cette hypothèse restreint les orbites possibles à certaines orbites stables, l'atome forme ainsi un système quantifié. Les résultats du calculs sont conformes à l'expérience.

C'est un système résonnant qui peut être calculé directement dans le cas de l'atome d'hydrogène qui ne comporte qu'un seul électron. Nous ne tiendrons compte que du nombre quantique principal [image] et pas des nombres quantiques secondaires [image] et [image].

Ce calcul est donc à à l'intersection de la mécanique classique, de la mécanique ondulatoire et de la mécanique quantique. Il en utilise d'ailleurs certains résultats, comme nous le verrons plus loin. Il n'en reste pas moins accessible à tous, ce qui n'est pas le cas d'un calcul efffectué totalement dans le formalisme de la mécanique quantique, avec l'équation de Schrödinger (voir la Bibliographie pour ceux qui veulent s'y lancer). Le résultat est précis (parce que nous connaissons les valeurs "qui marchent bien" des constantes physiques, certes).

Il ne faudra pas perdre de vue que compte tenu des résulats de la mécanique quantique, la position de l'électron dans l'atome ne peut pas être connue plus précisément qu'à 2 pi radians près... Ce qui signifie que cette position n'a pas de signification réelle.

Toutefois le côté résonnant de l'atome exposé ici est très parlant pour l'électronicien que je suis.

Pour aller plus loin, voir l'article l'Atome d'Hydrogène sur Wikipédia ainsi que les liens externes et la bibliographie au bas de cette page.

Hypothèses de base:

La description qui suit est celle d'un modèle (en l'occurrence le Modèle de Bohr). Ce modèle est une représentation mentale de ce que semble être la réalité telle que nous la mesurons grossièrement avec nos instruments. Ce n'est pas LA réalité. Ce modèle permet de calculer avec une certaine précision les raies spectrales de l'atome d'hydrogène, mais ne va guère au delà. En particulier il échoue dans le cas d'atomes plus complexes. La mécanique quantique qui a ensuite été développée permet d'aller beaucoup plus loin, alors même qu'elle est bien moins intuitive, ne permettant plus de se représenter une images simple de "la réalité", allant dans certaines de ses interprétations jusqu'à douter qu'il existe une réalité bien définie avant que nous la mesurions ("réduction du paquet d'ondes"). Et c'est très bien ainsi, une pierre dans le jardin de ceux qui pensent que le futur est déjà écrit dans un Grand Livre !

Il semblerait en effet que la nature à cette échelle ne se laisse pas si facilement dessiner, mettre en images fussent-elles mentales... Par exemple la représentation des particules accompagnée d'une "onde pilote" censée expliquer la "dualité onde-particule" (ou onde-corpuscule) suppose qu'il existerait bien une particule ponctuelle ayant une position et une vitesse bien définie simultanément accompagnée par une onde. Et bien c'est une façon de se raccrocher à des préjugés qui ne correspondent pas à ce que nous mesurons (remarque : ce que nous mesurons ne correspond pas non plus toujours à la réalité, lire les ouvrages d'Etienne Klein à ce sujet) ni à ce que nous disent les équations de la mécanique quantique. On aurait pu s'en douter lorsqu'on affirmait qu'une particule "élémentaire" possède une extension spatiale (taille) et un spin et qu'on suggère que le spin correspond à la rotation de cette entité de taille nulle. Il fallait oser ! Et comment un objet de taille nulle (ce qui devrait permettre de le situer dans l'espace avec une précision infinie) se révèle avoir des propriétés ondulatoires (qui correspondent à un flou total quant à la position) ? Et les relations d'incertitudes de la mécanique quantique nous interdisent de connaitre simultanémant la vitesse et la position de cette particule ponctuelle. Tout cela incite à penser que cette représentation d'une particule accompagnée de son onde pilote est un concept très... flou ! Et bien "pire": le test des inégalités de Bell par les expériences d'Alain Aspect ("paradoxe EPR") confortent la mécanique quantique dans ce qu'elle a de plus mystérieux : la non localité et l'intrication quantique. L'abandon du concept de particule ponctuelle me semble inévitable. La position ne se concrétise que lors de la mesure, lors d'une interaction avec une autre entité donc. Et avant la mesure il y avait quoi ? une onde ? oui sans doute. (remarque : l'expression "sans doute indique justement qu'il y a un doute !") Un "champ quantique" ? Oui, ça c'est pas mal ! Plusieurs champs quantiques de natures différentes ? Oui c'est encore mieux, afin de rendre compte de la pluralité des interactions connues. Et c'est quoi un champs quantique ? Ben c'est un truc qui se comporte comme un paquet d'onde qui peut se réduire en prenant l'aspect (vu par nos instruments) d'une particule... Faudrait quand même pas s'attendre à ce que les électrons soit faits de bois, les protons de silex et les neutrons de pâte à modeler ! Voire des micro-planètes avec des plantes et des animaux dessus !!

Sur la page d'entrée de ce site vous trouverez des articles avec liens vers des vidéos de conférences portant sur la mécanique quantique et les expériences d'Alain Aspect, ainsi que des conférences d'Etienne Klein. A voir absolument.

Toutes ces précisions pour dire que la mécanique quantique est une théorie merveilleusement passionnante, je vous en parlerai d'une manière plus mathématique prochainement. En attendant ces petits calculs sur le modèle de l'atome de Bohr permettent une approche approximative qui fonctionne... pas trop mal.

Voici donc les hypothèses simplissimes que nous retenons pour faire ces calculs :
L'atome d'hydrogène neutre est constitué d'un noyau (possédant un seul proton) autour duquel gravite un électron unique.
L'électron tourne autour du noyau de l'atome sur une orbite de rayon [image]. Pour l'orbite fondamentale, nous supposons le rayon de longueur constante (l'électron est considéré comme suivant une trajectoire circulaire) et la vitesse de rotation est supposée constante;
Nous avons:

Cte
= 0

Nous supposons à priori que la vitesse de l'électron n'est pas relativiste, ce qui se vérifiera ensuite.

Début du calcul:

L'accélération ayant pour expression:

Elle se simplifie, compte tenu de l'hypothèse de départ pour devenir:

Cette accélération est donc radiale centrée sur la noyau (la composante tangentielle suivant [image] est nulle) et son module est de valeur [image] le signe (-) indiquant qu'elle est dirigée en sens contraire de [image] , c'est à dire vers l'intérieur de la trajectoire (vers le centre du cercle), elle est dite centripète.

En valeur absolue cela donne:

La vitesse de l'électron sur son orbite est:

soit

Remarque: en électronique la fréquence est désignée par la lettre [image], en physique on emploie le lettre grecque [image] (nu)

L'électron de charge électrique négative ( [image]) subit la force électrostatique (loi de Coulomb) attractive de la part du noyau chargé positivement ( [image]), et que nous considèrerons comme immobile étant donné qu'il est 1800 fois plus massif que l'électron.

étant la charge de l'électron,

, [image] est la permittivité électrique du vide. (SI)

A cette échelle, la force d'attraction gravitationnelle, quant à elle, est négligeable devant cette force électrostatique.

L'énergie potentielle de l'électron soumis à cette force et à la distance r du noyau est:

Remarque: Energie négative:

Le signe (-) parce qu'il faut fournir de l'énergie à l'électron pour l'éloigner du noyau (et que l'énergie est nulle à l'infini, si on fournit l'énergie d'ionisation). Donc lorsque l'électron se trouve plus près du proton dans le champ coulombien, son énergie est inférieure à celle qu'il a lorsqu'il en est plus éloigné, inférieure donc à celle qu'il possède lorsqu'il en est infiniment éloigné, inférieure donc à zéro, c'est à dire négative.

Nous avons vu plus haut que l'accélération centripète [image] = [image] de l'électron. Cette accélération est due à la force électrostatique [image] par l'intermédiaire de la relation qui lie les forces et les accélérations de masses pesantes, à savoir la relation fondamentale de la dynamique

qui s'écrit ici

étant la masse de l'électron,

Vous ne m'entendrez pas souvent parler de « force centrifuge », si force centrifuge il y a, c'est le noyau qui la subit. Si on supprime instantanément le noyau d'un coup de baguette magique, l'électron filera tout droit (avec une trajectoire ortho-radiale et non pas radiale) et ce n'est certainement pas sous l'effet d'une quelconque « force centrifuge », c'est juste le principe qui veut qu'un corps en mouvement soumis à aucune force suit une trajectoire rectiligne à vitesse constante.

En rapprochant les équations (1) et (4) nous obtenons la condition d'équilibre de l'orbite:

En remplaçant [image] par sa valeur trouvée en (3) il vient:

Remplaçons [image] par sa valeur [image] trouvée en (2):

La vitesse [image] est donc telle que:

L'énergie potentielle calculée en (4) peut donc s'écrire:

D'autre part l'énergie cinétique de l'électron de masse [image] a pour expression

L'énergie totale de l'électron vaut donc:

Nous avons vu dès le départ (hypothèse de Louis de Broglie) que l'électron est associé à une onde (on peut dire qu'il se comporte comme une particule ou une onde, c'est suivant... c'est un objet quantique!) dont la longueur d'onde [image] est reliée à la quantité de mouvement de la particule par la relation:

étant la constante de Planck

et la quantité de mouvement valant:

Remarque:

Hypothèse de De Broglie pour une particule de masse non-nulle:

= impulsion

= vitesse de la particule

Prenons le cas du photon qui est une particule sans masse, mais qui possède un quanta d'énergie:

sa vitesse est [image] (vitesse de la lumière dans le vide)

ATTENTION: dans les lignes qui suivent je vais utiliser une notion de "masse équivalente à une énergie"
Qu'il soit bien clair que le photon n'a pas de masse, sa masse est NULLE, et que cette valeur E/c² que je vais utiliser est juste un tour de passe-passe qui permet d'obtenir un résultat troublant...

Donc, d'après la relation d'équivalence entre masse et énergie (relation d'Einstein [image]), l'énergie du photon est "équivalente" à une masse:

Cette « masse équivalente » ne conférerait-elle pas au photon une « impulsion » ?
L'Effet Compton montre que le photon à bien une impulsion (lors d'un choc entre un photon et électron, il y a conservation de l'impulsion, et on constate que la trajectoire de l'électron change, il se produit un « recul » de l'électron sous l'impulsion du photon)

Si cette « masse équivalente » était réelle, l'impulsion du photon (quantum d'impulsion) vaudrait:

Il se trouve que c'est la bonne valeur.

Reprenons maintenant l'hypothèse de de Broglie (1) et appliquons-la au photon compte tenu de ce dernier résultat (2):

or

il vient:

On retrouve ainsi la relation de Planck-Einstein [image] donnant la valeur de l'énergie du photon (quanta d'énergie) en fonction de sa fréquence.

Refermons cette parenthèse en retenant seulement que la masse du photon EST NULLE.

C'est la démonstration qu'on peut trouver des résultats exacts avec des hypothèses hasardeuses voire fausses!

( En fait de E=mc² il aurait fallu écrire E²= m²c⁴ + p²c² )

Revenons au calcul principal:

(11) et (12) donnent:

soit:

dans cette expression, remplaçons [image] par sa valeur [image] calculée en (7):

Nous allons maintenant poser une condition de résonance sur [image], ce qui va nous permettre de calculer [image].

La longueur [image] de l'orbite (supposée circulaire) vaut:

doit être un multiple de [image] de façon à obtenir une onde stationnaire:

(16) et (17) puis donnent:

élevons au carré:

remplaçons [image] par sa valeur trouvée en (15):

Le rayon [image] (et par conséquent la vitesse, l'énergie, le rayonnement) ne peuvent prendre que des valeurs discrètes, dites « quantifiées » en fonction de la valeur du nombre entier [image].

Ainsi [image] est un nombre quantique pour l'atome. Ce n'est pas le seul, il y en a d'autres qui définissent des modes de résonances plus complexes et se traduisent par des dédoublements des raies spectrales. Nous ne considèrerons que ce nombre quantique principal [image] dans cet article.

Pour n=1 l'atome se trouve dans son état d'énergie le plus bas possible, on dit qu'il est dans son état fondamental.

Les niveaux d'énergie de l'atome sont désignés par une lettre: K pour n=1, puis L, M, N, etc...

Application numérique:

6,626068 [image] 10-34

En faisant [image] nous obtenons le rayon de l'orbite la plus petite, dite première orbite de Bohr correspondant à l'état fondamental de l'atome:

soit environ 53 picomètres (0,053 nm)

On peut écrire le rayon [image] en fonction de cette orbite de Bohr:

Calcul du spectre d'émission

Nous avons vu en (10) que l'énergie totale de l'électron est égale à

La vitesse (7) comme le rayon est aussi quantifiée:

Remplaçons [image] par sa valeur quantifiée trouvée en (18)

soit:

en posant [image] il vient: ( [image] est la constante de Planck « réduite »)

Cette vitesse de l'ordre de [image] (pour n=1) est non relativiste (0,7% c) mais elle est quand même étonnamment grande, 2000 km/s (seconde, pas heure!) sur un cercle aussi petit de moins de un nanomètre! On peut donc s'attendre à une fréquence de révolution énorme. Calculons-la par curiosité (bien que la mécanique quantique nous indique que cela n'a pas vraiment de signification physique...)

(attention, ce n'est pas la fréquence des photons émis lors de transitions de l'électron entre différentes orbites, quoi que du même ordre de grandeur que celle de photons UV, comme nous le verrons. Rappelons que tant que l'électron reste sur une orbite stable il ne rayonne pas).

Calcul de l'énergie:

ou, en posant

L'énergie maximale pour [image] est égale à l'énergie d'ionisation, elle vaut:

et l'énergie [image] s'écrit alors:

Rayonnement:

L'électron ne peut se trouver que sur une des orbites permises correspondant à une valeur de [image] entière.

Un apport extérieur d'énergie (un photon incident) le fera "sauter" sur une orbite plus éloignée du noyau, et il « retombera » spontanément sur une orbite plus basse en émettant un photon d'énergie égale à la différence d'énergie entre celle qu'il avait sur l'orbite de départ et celle qui lui reste sur l'orbite d'arrivée.

Si donc on considère les valeurs [image] et [image] du nombre quantique [image] correspondant à ces énergies de départ et d'arrivée, [image] et [image] étant des nombres entiers, on obtient des photons émis ayant comme énergie:

Le photon émis aura une fréquence telle que

Les fréquences émises seront donc:

Et la longueur d'onde des photons émis sera:

= vitesse de la lumière dans le vide =

Calculons toutes ces valeurs avec un tableur (Le tableur libre Open source de open office):

Toutes ce valeurs découlent du résultat Eo=13,6 eV.
Les valeurs données dans la littérature scientifique sont très très légèrement différentes)

Les longueurs d'ondes comprises entre 400 et 700 nm se trouvent dans le domaine visible par l'Homme. Elles correspondent à des transitions entre les orbites 3, 4, 5, 6, 7 et l'orbite 2. Les raies spectrales correspondantes forment la série dite "de Balmer"

Voici la partie du spectre rayonné correspondant à cette série de Balmer (tracé automatiquement avec GNUplot):
Seules les trois raies les plus à droites sur ce graphique sont vraiment visibles. J'ai rajouté les couleurs approximativement...

La raie la plus lumineuse (rouge à 658,28 nm) qui correspond au saut entre le troisième et le second niveau d'énergie est appelée H alpha.
Elle est bien connue des astronomes qui utilisent des filtres adaptés pour augmenter le contraste des nébuleuses rayonnant principalement à cette longueur d'onde.

Liens externes:

  • http://fr.wikipedia.org/wiki/Spectre_de_l'atome_d'hydrogène
  • http://fr.wikipedia.org/wiki/Atome_d'hydrogène
  • http://fr.wikipedia.org/wiki/Orbitale_de_l'atome_d'hydrogène
  • http://fr.wikipedia.org/wiki/Théorie_de_Schrodinger_de_l'atome_d'hydrogène
  • http://fr.wikipedia.org/wiki/Hypothèse_de_De_Broglie
  • http://fr.wikipedia.org/wiki/Série_de_balmer
  • http://fr.wikipedia.org/wiki/H_alpha

Bibliographie:

  • Le cours de Physique de FEYNMAN. mécanique quantique. Chapitre 19: l'Atome d'hydrogène. DUNOD (2000) - Dans lequel Feynman résout l'équation de Schrödinger.
  • Le cours de Physique de FEYNMAN. mécanique quantique. Chapitre 2: La relation entre les points de vue ondulatoire et corpusculaire. Dans lequel Richard Feynman calcule la taille de l'atome d'hydrogène d'un manière surprenante (en trois lignes, par le calcul du minimum d'énergie en annulant sa dérivée)
  • PHYSIQUE MP2/PC2 tome 2: caractère quantique - matière et rayonnement. par C Janot et M. Gerl collection HACHETTE UNIVERSITE (1970) (grand classique des universités)
  • PHYSIQUE Terminale C.E (1983) Auteurs: Alain Pénigaud, Lucien Quaranta, Jean Duboc. chez FERNAND NATHAN


Transformée de Laplace

Nous avons vu que les développements en série de Fourier des fonctions périodiques permettaient d'effectuer des calculs sur des signaux périodiques de forme quelconque. C'était l'objet de l'analyse harmonique.

La transformée de Laplace, quant-à elle, permet de faire des calculs sur des signaux de forme quelconque non périodiques, en particulier des signaux dit impulsionnels. C'est l'objet du calcul opérationnel. Dans le domaine de l'électronique nous serons ainsi amenés à définir des impédances et des fonctions de transfert opérationnelles, de la même manière que nous avions défini des impédances complexes, afin de calculer la réponse impulsionnelle à ces signaux.

Nous pouvions déjà déterminer ces réponses en résolvant des équations différentielles comme nous l'avons fait dans le cas de la charge d'un condensateur avec une résistance. Mais pour des circuits plus complexes, et donc des équations différentielles plus complexes (d'ordre supérieur à 2) la résolution directe n'est plus envisageable alors que le passage par la transformée de Laplace le permet, en remplaçant la résolution des équations différentielles par un simple calcul algébrique.

Définition

Soit [image] une fonction de la variable [image] (pour nous, électroniciens, ce sera le temps) définie pour

La transformée de Laplace de la fonction [image] est notée [image] et vaut:

étant un instant aussi proche de zéro qu'on veut mais antérieur à

avec

Remarques:

Rien de bien méchant, l'intégrale on connait, l'exponentielle aussi... ça a un petit air de transformée de Fourier... en remplaçant [image] par [image] et avec des bornes d'intégration différentes.

Les transformées de Laplace concernent ce qui se passe APRES l'instant [image].

peut aussi être un nombre complexe.

Quelques Transformées de Laplace

(Fonction unité ou de Heaviside)

La fonction Echelon (ou unité) se note aussi

avec

Impulsion de Dirac

L'impulsion de Dirac, (on dit aussi « un Dirac » et ce n'est pas à proprement parler une fonction) notée [image] est la limite lorsque [image] tend vers 0 de la fonction rectangulaire (un top) de durée [image] et de hauteur [image] (la surface [image] =1 restant constante et valant 1, sa hauteur tend vers l'infini pour une durée nulle, une sorte de laser méga-watt-femto-seconde...)

Démonstration:

en effet

Démonstration de cette limite:

et donc, en cuisinant un peu les signes:

Comme vous le voyez, le calcul de la transformée de Laplace de l'impulsion de Dirac n'est pas tout simple lorsqu'on entre dans le détail, mais le résultat, lui, est on ne peut plus simple!


Silicium628

ELECTRONIQUE PROGRAMMABLE

Théorie et Applications
  • Math
  • Physique
    • Mesure de la vitesse de la lumière
      • Avec un laser
      • Avec une ligne de Lecher
    • Calcul de l'atome d'hydrogène
    • Grandeurs physiques et équations aux dimensions
    • Notion de champ électrique
    • Ondes Progressives et Stationnaires
  • Astrono
    • GO-TO pour monture équatoriale
    • Existe-t-il des univers multiples ?
  • ATmega
    • Programmation des ATmega en C
    • Geany comme EDI pour programmer les ATmega en C
    • Comment relier électriquement une SD card à un ATmega
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Géné 1Hz à 100MHz à DDS AD9850 piloté par GPS
    • Un distributeur de nourriture (ATmega8)
    • Programmateur pour Lave Linge (ATmega32)
    • Capacimètre Numérique (ATmega8)
    • Contrôleur pour moteur Brushless (ATmega8)
  • Arduino
    • La Transformée de Fourier Rapide sur ATmega ET Arduino
    • Geany comme EDI pour programmer les ARDUINO
    • Machine CNC de phototraçage de typons par diode laser 405nm
  • HF
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
    • Géné HF 90MHz sinus
    • Géné HF 160MHz sinus
    • Géné HF 1Hz à 40MHz sinus + DCF77 (DDS AD9850 + ATmega8)
    • Wobulateur 40MHz (DDS AD9850 et ATmega8)
    • Générateur de fréquences numérique
    • Oscillateur à NE555
  • GPS - Rubidium
    • Géné 1Hz à 100MHz à DDS AD9951 synchronisé par GPS
  • Automat
    • Un distributeur de nourriture
    • Déclencheur auto pour APN
    • Programmateur pour Lave Linge
    • Positionneur parabole TV satellite
    • DIGIPRESS-96 coffrage-sous vide
  • Mesure
    • Capacimètre Numérique
    • Le CAPACIM 97 pour accus
    • Grip-Dip
  • Aéro
    • Variateur électronique pour moteur SPEED 400
    • Contrôleur (variateur) pour moteur Brushless (avec un PIC16F628)
    • Contrôleur (variateur) pour moteur Brushless (avec un ATmega8)
    • Variateur double pour hélico indoor
  • Alims
    • Alim stabilisée 20V 5A à découpage
    • Alim 20V 4A à découpage, numérique pilotée par ATmega8
    • Nouvelle Alim 20V 4A à découpage, numérique pilotée par ATmega8
  • Progr
    • Programmer en C et Qt4 pour Linux
    • Programmer en C++ et Qt4 sur RASPBERRY PI
    • Décodage d'une trame RC5 (télécommande TV)
    • Programmation des AVR en langage C, sous LINUX
    • Planétarium en C++ & Qt4
    • Visualiseur d'images stéréoscopiques en C++ & Qt4
    • Transformée de Fourier (Programme en C++ et Qt4)
    • Transformée de Fourier Rapide FFT (Programme en C++ et Qt4)
  • 3D
    • Méthode de visualisation d'images en relief
  • MUSIQUE
  • Vidéo
  • LIVRES
    • Afficher tous les titres
  • Mes sites
    • (dont je suis le concepteur)
    • BOUB'ART Sculpture
    • BOUB'ART Recup

Pourquoi ce site

Je vous expose ici quelques réalisations personnelles dans le domaine de l'électronique, dans un but pédagogique en ce sens que je m'efforce d'en expliquer la conception, le fonctionnement, et aussi la théorie. J'espère ainsi démystifier cette discipline, car bien qu'elle soit omniprésente autour de nous, elle n'en demeure pas moins un peu "magique" ou plus simplement semble hors de portée pour la plupart des gens. Au XIXe siècle toute personne normalement instruite pouvait connaitre les principes de l'électricité expliquant le fonctionnement des moteurs, dynamos, lampes et téléphones de l'époque. Au XXe siècle les choses se compliquèrent un peu avec la radiophonie et la télévision, mais restaient à portée d'explications simples. Mais depuis l'apparition des circuits intégrés et plus précisément des microcontrôleurs qui sont de mini ordinateurs faisant tourner un programme informatique "embarqué" (et que l'on rencontre partout, de la montre bracelet aux circuits de freinage ABS, téléphones "mobiles" etc...) il est devenu courant de ne plus se casser la tête pour en comprendre le fonctionnement, affaire uniquement de spécialistes dit-on. ET BIEN NON ! Je dis que les choses restent compréhensibles pour tout un chacun, et j'espère le prouver ici.

REALISATIONS PERSO
Simulation d'un circuit LC en quelques lignes de C++
23 mai 2016 Ces quelques lignes suffisent pour résoudre numériquement une équation différentielle du deuxième ordre....
Horloge pilotée par GPS
31 dec 2015 C'est une alternative aux horloges et montres pilotées par DCF77, tout le monde ne résidant pas dans un rayon de 500km de la ville allemande...
INDUCTANCEMETRE
10 oct 2015 Si vous disposez d'un fréquencemètre montant à 200MHz (ou plus) ou d'un analyseur de spectre (ou les deux), ce petit circuit oscillateur vou...
SDcard data Recorder - ATmega32 + LCD 5110
10 juil 2015 Ce montage permet d'enregistrer en temps réel, c'est à dire rapidement, une grande quantité de données logiques. Je l'ai conçu afin de surve...
Récepteur Radio FM avec un TEA5767 + ATmega8
30 mai 2015 Le TEA5767 est souvent présenté sur le net, mais presque toujours piloté par un Arduino. Cette réalisation n'utilise pas un Arduino ni les b...
Asservissement de la puissance d'une diode Laser 405nm
26 mar 2015 Comment asservir précisément la luminosité d'une diode laser. Cet article est la suite logique de celui décrivant le photo-traceur laser ....
Machine CNC de phototraçage de typons par diode laser 4...
10 oct 2014 Je vous décris ici ma réalisation (en cours) d'une petite CNC (Machine à commande numérique) de flashage par laser de typons pour la fabrica...
Oscillo HAMEG HM303-4 : ajout d'un ATmega 8 !
05 oct 2014 Un sélecteur digital pour la base de temps....
Géné VHF 1Hz à 100MHz à DDS AD9951 piloté par GPS
29 août 2014 Le but de cette étude n'est pas de réaliser un émetteur de radio mais un générateur de laboratoire de très faible puissance (...
Comment utiliser Geany en remplacement de l'EDI Arduino
28 août 2014 Sur le wiki officiel Arduino se trouve une liste d’outils alternatifs à l'IDE parmi lesquels figure Ino, un petit outil en ligne de commande...
Encodeur rotatif digital sur ATmega8
20 août 2014 Ce type de composant est extrêmement utile pour incrémenter un nombre, une fréquence par exemple, en tournant un simple bouton. Son utilisat...
Transformée de Fourier sur ATmega32 et Arduino Mega2560
24 juin 2014 La rapidité d'exécution du calcul est essentielle lorsqu'il s'agit de traiter un signal en temps réel. Elle déterminera la fréquence maximal...
Existe-t-il des univers multiples ?
11 juin 2014 Et si notre Univers n’est qu’un parmi d’autres ? Entretien avec le cosmologiste Aurélien Barrau (LPSC, CNRS-IN2P3-UJF-INPG) Podcasts paru ...
LE COURS DE PHYSIQUE DE FAYNMAN - ELECTROMAGNETISME 1
05 juin 2014 Une vision personnalisée de l'enseignement de la physique par un Prix Nobel. ...
ALIMENTATION 20V - 5A à découpage, numérique, pilotée p...
22 janv 2014 Cette réalisation est la suite logique de l'alimentation 20V à découpage, analogique, décrite sur ce site, qui me donne satisfaction depuis ...
Nouvelle ALIM 20V - 4A à découpage, numérique, pilotée ...
22 janv 2014 Cette réalisation est la suite logique de l'alimentation 20V à découpage, numérique, décrite sur ce site. Dans cette nouvelle version l'ATm...
La Transformée de Fourier
28 août 2013 C'est une extension des séries de Fourier, mais pouvant s'appliquer à des fonctions non périodiques. Elle permet d'obtenir le spectre (fréqu...
DIGIPRES 96 Dépressiomètre numérique pour le coffrage...
27 oct 2012 Le DIGIPRESS 96 permet de commander automatiquement une pompe à vide (moteur de frigo) afin d’obtenir une dépression réglable et stable pour...
OSCILLATEUR à NE555 Théorie et Pratique
16 oct 2012 Cette réalisation constitue l'application pratique de l'étude mathématique de la charge d'un condensateur au travers d'une résistance, expos...
Méthode de visualisation d'images en relief et programm...
04 août 2012 Vous avez un écran large (16x9) et vous voudriez bien regarder des photos en relief bien nettes avec tous leurs détails et vrais couleurs? V...
Wobulateur digital à DDS AD9850 (résolution 1Hz) piloté...
31 juil 2012 Cet article fait suite à celui décrivant un générateur HF 40MHz sinus basé sur ce même circuit DDS AD9850. ...
Générateur HF 1Hz-40MHz sinus purdigital à DDS AD9850 (...
31 juil 2012 Je possédais depuis plusieurs années d'un "générateur de fonction" 2MHz analogique du commerce (DF1641A) certes assez joli mais qui ne me do...
Programmation des AVR en C sous LINUX avec Kontroller...
11 juil 2012 Attention: Le programme Kontrollerlab qui était un IDE parfaitement adapté à la programmation des uC ATMEL AVR était lui même développé so...
Programmation des AVR en C sous LINUX avec Geany
11 juil 2012 Je vous présente ci-dessous la mise en oeuvre, le paramétrage et l'utilisation de l'IDE Geany sous LINUX. (pour être précis, Linux Mint 13 a...
Décodage d'une trame RC5 (télécommande TV) en langage C
27 juin 2012 Ou comment utiliser une télécommande infra-rouge pour piloter un microcontrôleur. J'ai écrit cette fonction en langage C que j'utilise, une...
Programmer en C et Qt4 pour Linux
27 juin 2012 Je programmais depuis des années en Pascal (Delphi) sous Windows. Désirant me passer totalement de cet OS, j'ai recherché des outils de prog...
Alimentation stabilisée 5A à DECOUPAGE 1,5 à 20 V
26 juin 2012 J'ai conçu cette alimentation afin d'assurer la mise au point de mon variateur pour moteur brushless décrit sur ce site. Le composant qui a...
Double Variateur pour moteurs à courant continu avec u...
26 juin 2012 Je décris ci-dessous une réalisation qui me donne satisfaction, sachant que je ne suis plus vraiment débutant en électroniqu...
Variateur (Contrôleur) pour moteur BRUSHLESS avec un ...
24 juin 2012 J'ai longuement décrit et expliqué ici mon variateur Brushless basé sur un PIC16F628. Suite à cette première réalisation, qui fonctionnait m...
Variateur (Contrôleur) pour moteur Brushless avec un ...
30 mai 2012 Je décris ci-dessous une carte électronique qui me donne satisfaction, sachant que je ne suis plus vraiment débutant en électronique. Ce mo...
Positionneur de parabole satellite TV avec un PIC16...
16 mai 2012 ...
PROGRAMMATEUR POUR LAVE LINGE basé sur un ATmega32 - ...
15 mai 2012 15 mai 2012: J'ai acheté en 2008 un lave linge dont le programmateur électronique à grillé au bout de 10 jours! Que faire dans ce cas? moi ...
Déclencheur automatique pour APN basé sur un Microcont...
13 mai 2012 Cet automatisme permet de piloter un servo-moteur du type de ceux utilisés en aéromodélisme ou en robotique de loisirs afin d'appuyer sur le...
Comment relier électriquement une SD card à un ATmega
26 avr 2012 Les uC ATmega d'AVR disposent d'une SPI (Serial Peripheral Interface) tout comme les cartes mémoires SDcard. Donc la liaison peut se faire d...
GOTO pour monture équatoriale ATmega32 + LINUXpour téle...
16 avr 2012 Nécessite une monture équatoriale ayant les deux mouvements RA et DEC équipés de vis sans fin sur roue dentée. ( et non pas une vis + butée ...
Mesure de la vitesse de la lumière - Seconde expérience...
16 avr 2012 Le principe de cette seconde expérience consiste à mesurer la distance séparant les ventres de tension VHF sur une ligne de Lecher alimentée...
Mesure de la vitesse de la lumière - Première expérienc...
15 avr 2012 Le principe de cette expérience consiste à mesurer le temps mis par un rayon laser pour faire l'aller retour entre le laser, un miroir situé...
Générateur HF90 à 160 MHz sortie sinussynthétisé par PL...
13 nov 2008 Le but de cette étude n'est pas de réaliser un émetteur de radio mais un générateur de laboratoire de très faible puissance (...
Variateur pour moteur Speed 400 avec un microcontrôle...
10 nov 2008 La carte électronique décrite ici permet de faire varier la vitesse de rotation d'un moteur de type "speed400" (ou équivalent) en fonction d...
Distributeur de nourriture pour petits animaux de comp...
24 oct 2008 Ce distributeur me permet de m'absenter un ou deux jours en laissant mon lapin nain seul à la maison. Quatre petites doses de nourriture (gr...
Générateur HF 40 à 90 MHz sortie sinus synthétisé par...
24 oct 2008 Le but de cette étude n'est pas de réaliser un émetteur de radio mais un générateur de laboratoire de très faible puissance, permettant d'ex...
GENERATEUR HF (2MHz) à synthèse de fréquence (Quartz -...
24 oct 2008 Je vous ai déjà parlé ici de ces puissants microcontrôleurs RISC que sont les AVR ATMEGA8-16. Voici mon deuxième montage réalisé autour d...
Programmation des AVR ATmega en langage C sous Linux
30 avr 2007 Depuis quelque temps une famille de microcontrôleurs monte en puissance et surtout voit son prix baisser et devient très facilement approvis...
CAPACIMETRE NUMERIQUEbasé sur un ATmega8
07 dec 2005 Je vous ai déjà parlé ici de ces puissants microcontrôleurs RISC que sont les AVR ATMEGA8-16. Voici ma première réalisation avec l'un d'e...
ARTICLES
La dualité onde-corpuscule avec des photons uniques.
04 juin 2014 Colloque de l'orme du 15/05/2008 par Alain ASPECT, Académie des Sciences et Institut d'Optique, Palaiseau. La dualité onde-corpuscule est à...
La Non-Séparabilité (intrication quantique)
04 juin 2014 Entretiens de grands physiciens français sur le thème de la non-séparabilité (intrication quantique). La Non-Séparabilité est un point cen...
L'étrangeté quantique - Serge Haroche
04 juin 2014 Entretien avec Serge Haroche, Professeur au Collège de France et titulaire de la chaire Physique quantique, prix Nobel 2012....
PHYSIQUE MP2 PC2 - 2 - caractère quantique - matière et...
06 juin 2014 Par Christian Janot et Maurice Gerl Professeurs à la Faculté des Sciences de Nancy COLLECTION HACHETTE UNIVERSITE Je vous ai scanné ci-des...
LE COURS DE PHYSIQUE DE FAYNMAN - ELECTROMAGNETISME 1
05 juin 2014 Une vision personnalisée de l'enseignement de la physique par un Prix Nobel. ...
Le monde quantique
05 juin 2014 La physique quantique, après trois quarts de siècle, n'en finit pas d'être moderne. Elle est présente quotidiennement dans les laboratoires ...
Au coeur de la mécanique quantique
07 juin 2014 Conférence dans le cadre des rencontres de l'Irfu (Institut de Recherche sur les lois Fondamentales de l'Univers) du 13/02/2013 par le profe...
Existe-t-il des univers multiples ?
11 juin 2014 Et si notre Univers n’est qu’un parmi d’autres ? Entretien avec le cosmologiste Aurélien Barrau (LPSC, CNRS-IN2P3-UJF-INPG) Podcasts paru ...
La dualité onde particule du photon - Alain Aspect
06 août 2014 Conférence du samedi 17 Mars 2012 par Alain Aspect, physicien français au théâtre de La-Celle-Saint-Cloud. Alain Aspect est connu pour avoir...
L'univers a-t-il connu un instant zero , avec Etienne ...
09 août 2014 Dans le cadre de son cycle de conférences « Les Entretiens d'Issy », Issy-les-Moulineaux a accueilli le 14 mars 2011, Etienne Klein qui diri...
Les tests et effets de la physique quantique
11 août 2014 L'UNIVERSITE DE TOUS LES SAVOIRS Conférence d'Alain ASPECT du 1er août 2000 Dans laquelle Alain Aspect explique clairement que dans les ex...
Débat sur la mécanique quantique, la notion de localité
12 août 2014 Juillet 2013, Claude Aslangul et Etienne Klein Où il est dit (par Etienne Klein) une chose fondamentale : "Ce que la théorique quantique n...
Les chasseurs de particules
30 août 2015 Les chasseurs de particules de Yuval Ne'eman (Auteur), Yoram Kirsh (Auteur) ISBN 2.7381.0684.6 EDITIONS ODILE JACOB - SCIENCES ...
L'Univers élégant
24 oct 2015 Un grand plongeon dans la Théorie des Cordes...
Léonard Susskind : Le paysage cosmique
24 oct 2015 Notre univers en cacherait-il des millions d'autres ?...
L'intrication quantique
26 sept 2016 Une vidéo de la série "ScienceEtonnante" dans laquelle l'intrication quantique est expliquée d'une façon claire et intelligente....
THEORIE
La Transformée de Fourier
28 août 2013 C'est une extension des séries de Fourier, mais pouvant s'appliquer à des fonctions non périodiques. Elle permet d'obtenir le spectre (fréqu...
Transformée de Fourier sur ATmega32 et Arduino Mega2560
24 juin 2014 La rapidité d'exécution du calcul est essentielle lorsqu'il s'agit de traiter un signal en temps réel. Elle déterminera la fréquence maximal...
Simulation d'un circuit LC en quelques lignes de C++
23 mai 2016 Ces quelques lignes suffisent pour résoudre numériquement une équation différentielle du deuxième ordre....
VECTEURS
01 juil 2016 Les vecteurs, les Espaces vectoriels. Les bases avant d'attaquer l'électromagnétisme et les Equations de Maxwell ...
Espaces Vectoriels
05 juil 2016 Les Espaces vectoriels. Définition, exemples, propriétés. Famille libre et génératrice. Base et dimension. ...
Espaces Vectoriels - Exemples commentés.
07 juil 2016 Espaces vectoriels, exemples commentés. ...
Les Applications linéaires
08 juil 2016 Les applications linéaires dans les espaces vectoriels et leur représentation matricielle. ...
Les Matrices
15 juil 2016 Les matrices (qui représentent les applications linéaires dans les espaces vectoriels). ...
Autres articles de Math
15 juil 2016 Voici une liste de mes articles de math, ayant bien entendu rapport avec l'électronique... ...
Applications linéaires : exemples concrets
18 juil 2016 Nous allons voir de plus près quelques exemples d'applications linéaires ...
Fonctions de plusieurs variables. Dérivée partielle. Le...
19 juil 2016 Etude de la dérivée partielle de fonctions de plusieurs variables qui sont incontournables. Le gradient. ...
Les champs scalaires et vectoriels. Présentation et exe...
08 août 2016 Les champs scalaires et vectoriels sont partout présents en physique. ...
Le flux d'un champ vectoriel
09 août 2016 Le flux d'un champ vectoriel à travers une surface. ...
La divergence d'un champ vectoriel
11 août 2016 La divergence est un scalaire obtenu en faisant le produit scalaire du vecteur opérateur nabla par un champ vectoriel. ...
Divergence du champ électrique - 1ere équ. de Maxwell.
15 août 2016 Nous allons calculer la valeur non nulle de la divergence du champ électrique dans un volume contenant l'origine. ...
Rotationnel d'un champ de vecteurs
21 août 2016 Le rotationnel d'un champ de vecteurs. Où l'on retrouve notre opérateur nabla. ...
Les Equations de Maxwell
23 août 2016 James Clerk Maxwell a contribué à l'unification de l'électricité et du magnétisme en une même théorie : l'électromagnétisme. ...
Le laplacien : Opérateur vectoriel du second ordre
25 août 2016 L'opérateur laplacien va nous permettre, appliqué aux équations de Maxwell, de décrire la propagation des ondes électromagnétiques. ...
Le rotationnel du rotationnel
28 août 2016 Démonstration d'une relation fondamentale : rot(rot)=grad(div)-laplacien ...
Les ondes électromagnétiques
29 août 2016 Comment on obtient l'équation d'onde électromagnétique à partir des équations de Maxwell. ...
Solution des équations de Maxwell
03 sept 2016 Résolution de l'équation des ondes. Ondes planes progressives. Comment se propagents les ondes électromagnétiques. ...
La Théorie de la relativité restreinte
11 sept 2016 Les équations de Maxwell sont relativistes. Nous allons le montrer, mais étudions au préalable la théorie de la relativité restreinte. ...
L'Electromagnétisme est une théorie relativiste
18 sept 2016 L'Electromagnétisme est une théorie relativiste. D'ailleurs historiquement c'est l'étude de l'électricité et du magnétisme qui conduisit Ein...
Circulation d'un champ de vecteurs
26 sept 2016 La circulation d'un champ de vecteurs est liée au rotationnel du champ. Cette circulation va nous être utile pour démontrer que l'électromag...
MUSIQUE
Hotel California - Gabriella Quevedo
24 mar 2017 Gabriella Quevedo interprète Hôtel California du groupe Eagle....
Cynthia Lin Music chante Stand By Me ( Ukulele )
24 mar 2017 Une artiste qui chante (très bien) en s'accompagnant d'un instrument tout simple : C'est tout ce que j'aime. ...
Cynthia Lin Music chante Somewhere Over the Rainbow ( ...
24 mar 2017 C'est une leçon de Ukulele... ça donne envie d'apprendre à en jouer. Il faut que je commence par supprimer deux cordes à ma guitare ??...
Here Comes The Sun - Gabriella Quevedo
24 mar 2017 Gabriella Quevedo joue admirablement cette chanson des Beatles. On ne s'en lasse pas. Bravo !...
Pauline Croze - Voce Abusou
24 mar 2017 Pauline Croze & Mario Broder interprètent la chanson brésilienne Voce Abusou. Michel Fugain nous l'avait fait connaître sous sa traduction e...
BOSSA NOVA : GAROTA DE IPANEMA par Halley Elden
25 mar 2017 ...
BOSSA NOVA interprétées par Margareth
25 mar 2017 interprétée par Margareth (?)...
Still Loving You (Scorpions) - Gabriella Quevedo
24 mar 2017 Gabriella Quevedo interprète Still Loving You (Scorpions)...
Another Brick In The Wall (Pink Floyd) - Gabriella Quev...
11 oct 2017 Gabriella Quevedo joue Another Brick In The Wall (Pink Floyd)...
[ Retour Accueil ]
Ce site est développé en PHP avec des LOGICIELS LIBRES sous LINUX